Bug 109907 - rsync crashes trying to decompress when it cant compress data
rsync crashes trying to decompress when it cant compress data
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: rsync (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-12 15:26 EST by Dave Jones
Modified: 2015-01-04 17:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-16 14:29:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2003-11-12 15:26:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030 Galeon/1.3.10

Description of problem:
I had ISOs in a dir locally, and updated ISOs on a remote server.
I tried to update them with..

(19:05:58:davej@delerium:iso)$ rsync -e ssh -avz --progress
servername.com/path-to-isos/ .
davej@servername.com's password:
receiving file list ...
7 files to consider
./
disc1-ftp.iso
inflate returned -3 (0 bytes)    0:46:51
rsync error: error in rsync protocol data stream (code 12) at token.c(416)
rsync: connection unexpectedly closed (194 bytes read so far)
rsync error: error in rsync protocol data stream (code 12) at io.c(165)

(19:08:37:davej@delerium:amd64-iso)$

As the ISOs contain compressed RPMs, and ssh also uses compression,
I'm guessing that rsync couldn't compress further, but the local side
couldn't handle this situation.

I retried, got the same error and then just rm'd and started a fresh
rsync.


Version-Release number of selected component (if applicable):
rsync-2.5.6-19

How reproducible:
Always

Steps to Reproduce:
1. See description
2.
3.
    

Additional info:
Comment 1 Mike McLean 2003-11-12 15:46:02 EST
hmm, 
  rsync -e ssh -avz --progress user@server:/path/to/isos .
works for me.  On the client side I have rsync-2.5.6-19 (from FC1) and
on the server side I have rsync-2.4.6-13 (from RH7.2 errata).

also running the rsync against localhost on the FC1 box seems to be
working.
Comment 2 Hardy Merrill 2003-11-12 17:34:38 EST
I was also able to successfully run
   rsync -e ssh -avz --progress user@server:/path/to/isos .
My client is RHL9 running rsync-2.5.6-19, and the server side is
running rsync-2.5.6-19 on FC1.

Davej, is it possible for you to make one of those "iso with
compressed RPM's" available for me to grab?
Comment 3 Wayne Davison 2005-08-15 17:31:37 EDT
Rsync 2.6.4 contains a fix for a compress problem when sending large files.  I
think it should fix this.
Comment 4 Dave Jones 2005-08-16 14:29:37 EDT
I've not been able to reproduce this for since I reported it, so I'm ok with
this being closed. (Its also against an EOL product).

Note You need to log in before you can comment on or make changes to this bug.