Bug 1099144 - Some vmcores kernel version not detected - log shows "Parsing kernel version '%s'" - using "Kernel VRA / Version" explicitly works
Summary: Some vmcores kernel version not detected - log shows "Parsing kernel version ...
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: retrace-server
Version: el6
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: ---
Assignee: Michal Toman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-19 14:47 UTC by Dave Wysochanski
Modified: 2015-04-01 13:32 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-08-15 18:57:56 UTC


Attachments (Terms of Use)

Description Dave Wysochanski 2014-05-19 14:47:28 UTC
Description of problem:
We had a RHEL5 (2.6.18-308.el5 x86_64) vmcore come in, and the kernel version was not detected properly by retrace-server.  Re-queueing with 'custom core location' and 'kernel VRA' of '2.6.18-308.el5.x86_64' worked fine though.


Version-Release number of selected component (if applicable):
retrace-server-1.11-4.el6.noarch


How reproducible:
Every time with this one vmcore.  Not sure how many other vmcores are affected, but my guess is it is not a widespread problem.  Once someone gets a better handle on the root of the problem, we can probably look at the failed vmcores we have and determine how many of failed vmcores are due to this problem, as well as a how many vmcores overall are affected by this problem.


Actual results:
kernel version not detected, need to use "kernel VRA" and resubmit


Expected results:
Should automatically detect RHEL4 - RHEL7 vmcores with known erratas / kernel-debuginfos


Additional info:
I'll attach links to the failed vmcore and save it off for a testcase.

Depending on how involved a fix is, we may need to be very careful to not introduce a regression.  Any fix should be tested against a lot of vmcores.

From what I can tell, I think most vmcores kernel versions are detected fine, and there is a workaround for this problem to use "kernel VRA".  We can at least make sure the workaround is properly documented.

Filing as severity 'low' and priority 'low' based on the fact we have a workaround, and I think this affects a small number of vmcores.

Comment 2 Michal Toman 2014-06-10 09:07:34 UTC
Retrace Server looks for 'OSRELEASE=kernel-version' env variable in the vmcore. Some vmcores contain just 'OSRELEASE=%s' so the '%s' was considered kernel version. Fixed in upstream.

commit 134f2791a7cd44e1a8a1c922723156a145d6bc89
Author: Michal Toman <mtoman@redhat.com>
Date:   Tue Jun 10 11:00:53 2014 +0200

    get_kernel_release: do not match 'OSRELEASE=%s'
    
    Signed-off-by: Michal Toman <mtoman@redhat.com>

Comment 6 Dave Wysochanski 2014-07-28 14:40:08 UTC
I'm pretty sure one 'signature' for this bug is if a task fails with "kernel version '%s'"

DEBUG:root:   2014-07-25 05:56:31 Parsing kernel version '%s'
ERROR:root:   2014-07-25 05:56:31 need more than 1 value to unpack
WARNING:root: 2014-07-25 05:56:31 prepare_debuginfo failed: Unable to determine kernel version

Comment 7 Fedora Update System 2014-07-31 11:52:41 UTC
retrace-server-1.12-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/retrace-server-1.12-2.el6

Comment 8 Fedora Update System 2014-07-31 16:58:56 UTC
Package retrace-server-1.12-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing retrace-server-1.12-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-2089/retrace-server-1.12-2.el6
then log in and leave karma (feedback).

Comment 11 Dave Wysochanski 2014-08-04 20:51:57 UTC
This is fixed in retrace-server-1.12-2.el6.noarch.
Verified by submitting two vmcores which previously failed.

Comment 14 Fedora Update System 2014-08-15 18:57:56 UTC
retrace-server-1.12-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.