Bug 109924 - All ethernet ports are not configured when Intel dual port cards are added
All ethernet ports are not configured when Intel dual port cards are added
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-12 19:36 EST by Ken Franklin
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 23:34:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken Franklin 2003-11-12 19:36:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

Description of problem:
On a V65x server, when 6 intel pro/1000 dual port ethernet cards are
added, kudzu asks for configuration information for the 12 new ports
but only 10 are brought up at boot time.

All ports have been cabled to live ports on a hub.

Initially the server is booted with empty card slots.  The on-board
ports (eth0 and eth1) are configured correctly and come up after boot.
 Next, the 6 dual port cards are installed and cabled.  Kudzu sees the
additions and configures 12 new ports (I set them to DHCP).  As the
boot continues there should be a total of 14 ports but only 12 are
brought up.

In /etc/sysconfig/network-scripts there are script files for 12 ports
ifcfg-eth0 through ifcfg-eth11.  The last two are missing.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RH9 with empty PCI slots and boot the server
2.shutdown the server
3.install 6 Intel Pro/1000 MT dual port cards and cable them
4.Boot the server, note kudzu prompts for 12 interfaces
5.configure the interfaces via kudzu and complete the boot
6.log in as root and check /etc/sysconfig/network-scripts for 14
scripts.  Note there are only 12.
    

Actual Results:  12/14 ports are configured

Expected Results:  14 / 14 ports should be configured

Additional info:
Comment 1 Bill Nottingham 2003-11-12 21:27:34 EST
Please test a later release, such as Fedora Core 1, or RHEL 3.
Comment 2 Ken Franklin 2003-11-14 11:47:39 EST
The problem was see by one of our customers who corrected it by taking
the following action...

<snip>
the RH Anaconda installer set a buffer of 200
bytes to the list of all drivers to be loaded. This buffer is used in
the process of creating module.conf. 200 bytes were not enough to
include all 14 instances of the e1000.o driver.We've
changed the size of the buffer to 400 bytes.
<snip>
Comment 3 Ken Franklin 2003-11-14 13:14:02 EST
I completed the test with RHEL 3 and found that 11/14 ports are
configured.
Comment 4 Jeremy Katz 2004-10-04 23:34:56 EDT
This should be better with newer releases.

Note You need to log in before you can comment on or make changes to this bug.