Bug 1099275 - mailx documentation has conflicting information about environment vairables and config files
Summary: mailx documentation has conflicting information about environment vairables a...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides
Version: 6.5
Hardware: All
OS: Linux
medium
low
Target Milestone: rc
: ---
Assignee: Jan Chaloupka
QA Contact: Iveta Wiedermann
URL:
Whiteboard:
Keywords: ManPageChange, Patch
Depends On:
Blocks: 1109294 1119276
TreeView+ depends on / blocked
 
Reported: 2014-05-20 01:54 UTC by GE Scott Knauss
Modified: 2018-12-05 18:38 UTC (History)
6 users (show)

(edit)
Cause: incomplete information about unsetting of environment variables were presented

Consequence: information of possible unsetting of environment variables were missing

Fix: information about unsetting of environment variables provided

Result: man page is updated
Clone Of:
: 1109294 (view as bug list)
(edit)
Last Closed: 2014-10-14 07:27:11 UTC


Attachments (Terms of Use)
mailx.1: environment variables conflict (723 bytes, patch)
2014-06-06 12:39 UTC, Jan Chaloupka
pschiffe: review+
Details | Diff
mailx-12.4-man-variable.patch (605 bytes, patch)
2014-06-09 12:53 UTC, Peter Schiffer
no flags Details | Diff
mailx-12.4-man-variable.patch (604 bytes, patch)
2014-06-09 16:23 UTC, Peter Schiffer
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1382 normal SHIPPED_LIVE man-pages-overrides bug fix update 2014-10-14 01:21:54 UTC

Description GE Scott Knauss 2014-05-20 01:54:45 UTC
Description of problem:

The man page contains the following:

"
NOTES

       Variables in the environment passed to mailx cannot be unset.
"

<snip>
"
   Variable options
       Options are controlled via set and unset commands,  see  their  entries
       for  a  syntax  description.   An option is also set if it is passed to
       mailx as part of the environment (this is not  restricted  to  specific
       variables  as  in the POSIX standard).  A value given in a startup file
       overrides a value imported from the environment.  Options may be either
       binary,  in  which  case it is only significant to see whether they are
       set or not; or string, in which case the actual value is of interest.

"

The first appears to be the current state of the code.


Version-Release number of selected component (if applicable):
12.4-7.el6.x86_64

How reproducible:

man mailx


Steps to Reproduce:

1. mail mailx 

Actual results:

See Description

Expected results:

The sentence "A value given in a startup file overrides a value imported from the environment." should be removed from the man page.


Additional info:

This issue was found when the user upgraded from RHEL 5 to RHEL 6 and a script failed due to the debug variable being defined as a function in a script that also called mailx. This caused mailx to go in to debug mode and not send email.

Comment 2 Jan Chaloupka 2014-06-06 08:48:17 UTC
Does it make sence for ou, Peter, to remove the sentence "A value given in a startup file overrides a value imported from the environment."?

Comment 3 Peter Schiffer 2014-06-06 10:32:55 UTC
Yes, it looks reasonable. Thanks.

Comment 4 Jan Chaloupka 2014-06-06 12:39:46 UTC
Created attachment 902912 [details]
mailx.1: environment variables conflict

Removing the sentence.

Comment 5 Thomas Gardner 2014-06-06 17:10:21 UTC
(In reply to Jan Chaloupka from comment #2)
> Does it make sence for ou, Peter, to remove the sentence "A value given in a
> startup file overrides a value imported from the environment."?

This does NOT sound reasonable to me.  I believe that sentence is still true.  I believe value GIVEN in a startup file does override a value imported from the environment.  The only thing is that a value from the environment can't be unset from the config file, only overriden with a new value.  I think the sentence needs to be there or the user will have no idea.  I would just repeat the caveat given at the end of the man page here, that's all.

Please, don't remove that sentence unless someone has found that it's not true.

Comment 6 Peter Schiffer 2014-06-09 12:53:40 UTC
Created attachment 904655 [details]
mailx-12.4-man-variable.patch

Ah, right. Override doesn't mean only unset. Thanks Thomas. I've updated the patch.

Comment 8 Peter Schiffer 2014-06-09 16:23:57 UTC
Created attachment 904792 [details]
mailx-12.4-man-variable.patch

fixed grammar

Comment 23 errata-xmlrpc 2014-10-14 07:27:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1382.html


Note You need to log in before you can comment on or make changes to this bug.