Bug 1099289 - typo error in man page
Summary: typo error in man page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-what
Version: 7.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1288337 1301891
TreeView+ depends on / blocked
 
Reported: 2014-05-20 02:57 UTC by jiyu
Modified: 2016-11-04 07:02 UTC (History)
8 users (show)

Fixed In Version: virt-what-1.13-7.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 07:02:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2469 normal SHIPPED_LIVE virt-what bug fix update 2016-11-03 14:07:01 UTC

Description jiyu 2014-05-20 02:57:43 UTC
Description of problem:
manual page | wrong word | correct word
------------+------------+-----------
virt-what.1 | confimed   | confirmed

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Server release 7.0 (Maipo)

How reproducible:
always

Steps to reproduce:
1. man <anything-from-1st-column>
2. search for <anything-from-2nd-column>

Actual results:
There are typo errors in the man page.

Expected results:
There are no typo errors in the man page.

Comment 12 Xianghua Chen 2016-04-20 09:46:35 UTC
Checked the source package and the typo error is still there. Ignore comment 10 pls.

Comment 13 Richard W.M. Jones 2016-06-20 12:24:26 UTC
As virt-what is on the ACL for RHEL 7.3, we can fix this in the
main package now.

Comment 15 Xianghua Chen 2016-06-28 06:40:32 UTC
It still failed with the packages:
virt-what-1.13-7.el7.src.rpm

Steps:
1. Download the src.rpm:
# wget http://download.eng.bos.redhat.com/brewroot/packages/virt-what/1.13/7.el7/src/virt-what-1.13-7.el7.src.rpm
# rpm2cpio virt-what-1.13-7.el7.src.rpm|cpio -div
# tar -zxvf virt-what-1.13.tar.gz
# cd virt-what-1.13
# ./configure ; make
# man ./virt-what.1

Search for "confimed" and it's still there:
powervm_lx86
           The guest is running inside IBM PowerVM Lx86 Linux/x86 emulator.

           Status: data originally supplied by Jeffrey Scheel, confimed by
           Yufang Zhang and RWMJ


So change to ASSIGNED.

Comment 16 Richard W.M. Jones 2016-06-28 08:12:11 UTC
(In reply to Xianghua Chen from comment #15)
> It still failed with the packages:
> virt-what-1.13-7.el7.src.rpm
> 
> Steps:
> 1. Download the src.rpm:
> # wget
> http://download.eng.bos.redhat.com/brewroot/packages/virt-what/1.13/7.el7/
> src/virt-what-1.13-7.el7.src.rpm
> # rpm2cpio virt-what-1.13-7.el7.src.rpm|cpio -div
> # tar -zxvf virt-what-1.13.tar.gz
> # cd virt-what-1.13
> # ./configure ; make
> # man ./virt-what.1
> 
> Search for "confimed" and it's still there:
> powervm_lx86
>            The guest is running inside IBM PowerVM Lx86 Linux/x86 emulator.
> 
>            Status: data originally supplied by Jeffrey Scheel, confimed by
>            Yufang Zhang and RWMJ
> 
> 
> So change to ASSIGNED.

Not sure what method you're trying here, but this happens
because you're not applying the patches.

Anyway, don't unpack the source RPM.  Install the binary
RPM and test that instead.

Comment 17 Xianghua Chen 2016-06-30 07:57:37 UTC
I'm trying this way to avoid the effect by man-pages-overrides, but I forgot the patches thing, sorry about that. Change the method to:

Verified with the packages:
virt-what-1.13-7.el7.src.rpm

Verify steps:
1. Download the rpm:
# wget http://download.eng.bos.redhat.com/brewroot/packages/virt-what/1.13/7.el7/x86_64/virt-what-1.13-7.el7.x86_64.rpm
2. Extract the rpm package, and check the man page:
# rpm2cpio virt-what-1.13-7.el7.x86_64.rpm | cpio -div
# gunzip usr/share/man/man1/virt-what.1.gz
# man usr/share/man/man1/virt-what.1 

Search for "confimed" and it's not there anymore.

So verified.

Comment 19 errata-xmlrpc 2016-11-04 07:02:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2469.html


Note You need to log in before you can comment on or make changes to this bug.