Bug 1099395 - 3.3 agent dies when running in the cluster with 3.4 agent
Summary: 3.3 agent dies when running in the cluster with 3.4 agent
Keywords:
Status: CLOSED DUPLICATE of bug 1101299
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-ha
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Jiri Moskovcak
QA Contact: yeylon@redhat.com
URL:
Whiteboard: sla
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-20 08:31 UTC by Jiri Moskovcak
Modified: 2016-04-18 07:00 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-29 14:07:01 UTC
oVirt Team: SLA


Attachments (Terms of Use)

Description Jiri Moskovcak 2014-05-20 08:31:27 UTC
Description of problem:

on 3.3 host: ovirt-hosted-engine-ha-1.0.0-3.el6ev.noarch

ainThread::WARNING::2014-05-16 10:57:14,073::hosted_engine::336::ovirt_hosted_engine_ha.agent.hosted_engine.HostedEngine::(start_monitoring) Unexpected error
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/ovirt_hosted_engine_ha/agent/hosted_engine.py", line 329, in start_monitoring
    self._collect_all_host_stats()
  File "/usr/lib/python2.6/site-packages/ovirt_hosted_engine_ha/agent/hosted_engine.py", line 885, in _collect_all_host_stats
    in json.loads(md['engine-status']).iteritems()])
  File "/usr/lib64/python2.6/json/__init__.py", line 307, in loads
    return _default_decoder.decode(s)
  File "/usr/lib64/python2.6/json/decoder.py", line 319, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib64/python2.6/json/decoder.py", line 336, in raw_decode
    obj, end = self._scanner.iterscan(s, **kw).next()
  File "/usr/lib64/python2.6/json/scanner.py", line 55, in iterscan
    rval, next_pos = action(m, context)
  File "/usr/lib64/python2.6/json/decoder.py", line 171, in JSONObject
    raise ValueError(errmsg("Expecting property name", s, end))
ValueError: Expecting property name: line 1 column 1 (char 1)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Jiri Moskovcak 2014-05-20 08:34:56 UTC
Artyom,
since you've found this bug, can you please provide more info about it? 
1. package versions on both hosts (vdsm, ovirt-hosted-engine-ha)
2. engine version installed as HE

and whatever else you find useful for reproducing this issue.

Comment 3 Jiri Moskovcak 2014-05-29 14:07:01 UTC

*** This bug has been marked as a duplicate of bug 1101299 ***


Note You need to log in before you can comment on or make changes to this bug.