Bug 109940 - ACPI modules loaded using insmod instead of modprobe
Summary: ACPI modules loaded using insmod instead of modprobe
Status: CLOSED DUPLICATE of bug 107199
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: 1
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-13 05:43 UTC by Bojan Smojver
Modified: 2014-03-17 02:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:59:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bojan Smojver 2003-11-13 05:43:20 UTC
/etc/rc.d/rc.sysinit script, line 175 in FC1, goes like this:

insmod $module

The module here is a full path to the ACPI module in question. If
hardware doesn't support certain module (e.g. toshiba_acpi) this
causes ugly error messages being spewed out to the console. One can
turn such modules off in /etc/modules.conf, but error messages
persist. This can be solved by changing the above line to:

modprobe `basename $module .o`

Comment 1 Sergey V. Udaltsov 2003-11-13 09:49:33 UTC
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=107199 -
virtually same bug

Comment 2 Bastien Nocera 2003-12-20 01:40:36 UTC

*** This bug has been marked as a duplicate of 107199 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:59:58 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.