Bug 109945 - RFE: Use of ppp-watch for non ppp[0-9] interfaces
RFE: Use of ppp-watch for non ppp[0-9] interfaces
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: FutureFeature
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2003-11-13 04:44 EST by Pierre Ossman
Modified: 2014-03-16 22:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-20 16:23:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Complete patch (3.18 KB, patch)
2004-02-15 09:49 EST, Pierre Ossman
no flags Details | Diff

  None (edit)
Description Pierre Ossman 2003-11-13 04:44:03 EST
Description of problem:
ppp-watch as it is now calls ifup-ppp to bring up the interface.
I'd like it to call ifup instead allowing for more generic use. The
reason for this is that I'm using a VPN solution based on PPP over SSH
and ppp-watch is great for maintaining the integrity of the tunnel.
The system is designed to integrate into initscripts (so that one can
use ifup/ifdown vpn2) so I'd like to reuse as much of the framework as
possible. With the current layout, this isn't possible however...

I've done these patches myself and the tunnel system is very stable.
It would be nice to have these modifications (the ppp-watch patch, not
the tunnel system) in the main release so I wouldn't have to run a
modified version...

A summary of what I've done to make it work can be found at
http://projects.drzeus.cx/initscripts-generic
More or less all I've done is make ppp-watch call ifup and make sure
that the new scripts called can handle the "daemon" parameter that
ppp-watch provides. Also I had to tweak some other scripts to get
automatic routes to work.
Comment 1 Pierre Ossman 2004-02-15 09:49:18 EST
Created attachment 97686 [details]
Complete patch

Sorry it took so long but here is the patch against the current stable
initscripts (7.42.2-1 from FC1).

It also includes a fix for bug 92023 since it was difficult to do anything
useful with the tunnels witout this fix.
Comment 2 Miloslav Trmač 2006-03-20 09:46:55 EST
Hello,
is this still relevant?  http://projects.drzeus.cx/initscripts-generic/
says the user of these hooks is not developed anymore.
Comment 3 Pierre Ossman 2006-03-20 13:15:29 EST
Correct, they are not. So personally I don't care anymore. :)
Comment 4 Miloslav Trmač 2006-03-20 16:23:01 EST
Thanks.  In that case let's keep the current code, adding hooks without a known
user would just make possible changes in the future harder.

Note You need to log in before you can comment on or make changes to this bug.