Bug 10995 - Jade RPM has unusually huge librariy file
Summary: Jade RPM has unusually huge librariy file
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: jade (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-23 02:37 UTC by kumar1
Modified: 2014-03-17 02:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-24 14:49:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description kumar1 2000-04-23 02:37:23 UTC
The Jade RPM has two unusually large libraries /usr/lib/libsp.a and
/usr/lib/libstyle.a which in total encompass ~40MB iirc! If I strip them,
they go down to much more reasonable numbers so I don't know if the large
size was intentional or due to some inappropriate compile time options?

Comment 1 Bill Nottingham 2000-04-24 14:49:59 UTC
A combination; there were some odd compiler flags to work
around a compiler issue on alpha, but then we forgot to
strip the libraries.

Fixed in jade-1.2.1-10 in rawhide.


Note You need to log in before you can comment on or make changes to this bug.