Bug 109954 - file selection in file open dialog does not work
file selection in file open dialog does not work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-13 07:24 EST by Ian
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 11:41:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian 2003-11-13 07:24:58 EST
Description of problem: File Open file selection does not work.


Version-Release number of selected component (if applicable):
nedit-5.3-5


How reproducible:
Every time.

Steps to Reproduce:
1. Start nedit
2. Select File->Open
3. Try and select a file.
  
Actual results:
Cannot select a file.

Expected results:
Filename should become highlighted and filename appear
in filename box.

Additional info:
Nedit is linked against the openmotif-2.2.2 which has severe
bugs and is not recommended for use by the Open Motif group.

See: http://www.motifdeveloper.com/tips/tip22.html

Maybe it should be built against the openmotif-2.1 series.
Unfortunately the openmotif21-devel package is not included
in Fedora for me to try.
Comment 1 Tim Waugh 2003-11-13 07:28:46 EST
openmotif has bugs -> changing component.
Comment 2 Thomas Woerner 2004-01-15 10:17:25 EST
I can not reproduce this. 

I need more information:

- Which openmotif version are you using (version-release number)?
- When does this happen?
Comment 3 Ian 2004-01-15 10:41:31 EST
I have since found out this is a well known problem with KDE/nedit
interactions. I guess you won't see this in Gnome.

KDE tries to enforce it's colour schemes on a few well known
applications (nedit, xv, xpdf, etc.) see directory:

/usr/share/apps/kdisplay/app-defaults

Somehow the listselectors end up with the same colour for
highlighted text and non-highlighted text.

If you remove the Nedit.ad file in this directory the problem
is fixed at the expense of non-KDE colours within nedit.

An attempt has been made to fix this problem in nedit-5.4, from
Changelog:

2003-05-18 20:05  edg

        * source/: nedit.c (1.47), nedit.h (1.38): Workaround for KDE's
        FONTLIST bug (and for the various BACKGROUND and FOREGROUND
        resource values).
Comment 4 Thomas Woerner 2004-04-19 11:24:42 EDT
This is misconfiguration in
/usr/share/apps/kdisplay/app-defaults/Nedit.ad. -> Assigning to kdebase.
Comment 5 Ngo Than 2004-04-19 11:41:55 EDT
it's fixed now in kdebase-3.2.2-2. thanks for your report

Note You need to log in before you can comment on or make changes to this bug.