Bug 1099581 - 'pyanaconda.timezone.TimezoneConfigError' after completing initial-setup
Summary: 'pyanaconda.timezone.TimezoneConfigError' after completing initial-setup
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: initial-setup
Version: rawhide
Hardware: arm
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vratislav Podzimek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: ARMTracker F21AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2014-05-20 16:05 UTC by Paul Whalen
Modified: 2014-07-09 18:02 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-07-09 18:02:16 UTC


Attachments (Terms of Use)

Description Paul Whalen 2014-05-20 16:05:57 UTC
Description of problem:
After completing initial-setup system returns an error and changes are not applied. 

Version-Release number of selected component (if applicable):
anaconda-core-21.36-1.fc2

Steps to Reproduce:
1. Boot recent Minimal ARM Disk image
2. After completing initial-setup error is returned, changes not saved. 

Actual results:
Traceback (most recent call last):
  File "/usr/lib/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/usr/lib/python2.7/site-packages/initial_setup/__main__.py", line 126, in <module>
    section.execute(None, data, None)
  File "/usr/lib/python2.7/site-packages/pyanaconda/kickstart.py", line 1501, in execute
    timezone.write_timezone_config(self, iutil.getSysroot())
  File "/usr/lib/python2.7/site-packages/pyanaconda/timezone.py", line 142, in write_timezone_config
    raise TimezoneConfigError(msg)
pyanaconda.timezone.TimezoneConfigError: Error while writing /etc/adjtime file: No such file or directory

Expected results:
initial-setup saved.

Additional info:

Comment 1 David Shea 2014-05-20 16:50:40 UTC
Looks like the ROOT_PATH -> getSysroot change in anaconda breaks initial-setup.

Comment 2 Paul Whalen 2014-05-28 16:40:40 UTC
Thank you! Verified working on ARM minimal image.

Comment 3 Martin Kolman 2014-05-28 16:55:47 UTC
Nice! Good to hear that it's working now. :)


Note You need to log in before you can comment on or make changes to this bug.