Bug 1099676 - Unable to mock build EL7 SRPMs on EL6
Summary: Unable to mock build EL7 SRPMs on EL6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: mock
Version: el6
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1100178 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-21 00:36 UTC by Vinson Lee
Modified: 2014-10-10 16:04 UTC (History)
6 users (show)

Fixed In Version: mock-1.1.41-3.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-01 22:23:10 UTC


Attachments (Terms of Use)

Description Vinson Lee 2014-05-21 00:36:39 UTC
Description of problem:
Mock is unable to build EL7 SRPMs on EL6, due to an xz error.

Version-Release number of selected component (if applicable):
$ mock --version
1.1.38

How reproducible:
100%

Steps to Reproduce:
1. Download a EL7 SRPM.
2. mock -r epel-7-86_64 <SRPM>
3.

Actual results:
$ mock -r epel-7-x86_64 mock-1.1.38-1.el7.src.rpm 
INFO: mock.py version 1.1.38 starting...
Start: init plugins
INFO: selinux enabled
Finish: init plugins
Start: run
INFO: Start(mock-1.1.38-1.el7.src.rpm)  Config(epel-7-x86_64)
Start: lock buildroot
Start: clean chroot
INFO: chroot (/var/lib/mock/epel-7-x86_64) unlocked and deleted
Finish: clean chroot
Finish: lock buildroot
Start: chroot init
Start: lock buildroot
Mock Version: 1.1.38
INFO: Mock Version: 1.1.38
INFO: calling preinit hooks
INFO: enabled root cache
INFO: enabled yum cache
Start: cleaning yum metadata
Finish: cleaning yum metadata
INFO: enabled ccache
Start: device setup
Finish: device setup
Start: yum update
ERROR: Exception(mock-1.1.38-1.el7.src.rpm) Config(epel-7-x86_64) 0 minutes 6 seconds
INFO: Results and/or logs in: /var/lib/mock/epel-7-x86_64/result
ERROR: Command failed: 
 # ['/usr/bin/yum', '--installroot', '/var/lib/mock/epel-7-x86_64/root/', 'install', '@buildsys-build', '--setopt=tsflags=nocontexts']
Error: xz compression not available


Expected results:
Successful build.


Additional info:
Mock on Fedora 19 can build EL7 SRPMS.

Comment 1 Kevin Fenzi 2014-05-21 02:18:30 UTC
yum install pyliblzma

That will allow the rhel6 yum to handle the xz repodata in epel7.

Comment 2 Miroslav Suchý 2014-05-21 06:47:42 UTC
Yes, comment #1 is true.
Commited as c0346b1 into branch msuchy-work.

Comment 3 Pavel Raiskup 2014-05-22 08:00:31 UTC
*** Bug 1100178 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2014-05-27 15:39:35 UTC
mock-1.1.39-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.39-1.fc19

Comment 5 Fedora Update System 2014-05-27 15:39:51 UTC
mock-1.1.39-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.39-1.el6

Comment 6 Fedora Update System 2014-05-27 15:40:07 UTC
mock-1.1.39-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mock-1.1.39-1.fc20

Comment 7 Fedora Update System 2014-05-27 19:12:05 UTC
Package mock-1.1.39-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing mock-1.1.39-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-1506/mock-1.1.39-1.el6
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2014-06-01 22:23:10 UTC
mock-1.1.39-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2014-06-25 20:00:27 UTC
mock-1.1.39-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2014-07-18 02:13:34 UTC
mock-1.1.40-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mock-1.1.40-2.fc20

Comment 11 Fedora Update System 2014-07-18 02:13:58 UTC
mock-1.1.40-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.40-2.fc19

Comment 12 Fedora Update System 2014-07-18 02:14:21 UTC
mock-1.1.40-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.40-2.el6

Comment 13 Fedora Update System 2014-07-18 17:45:41 UTC
mock-1.1.41-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mock-1.1.41-1.fc20

Comment 14 Fedora Update System 2014-07-18 17:46:07 UTC
mock-1.1.41-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.41-1.fc19

Comment 15 Fedora Update System 2014-07-18 17:46:32 UTC
mock-1.1.41-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.41-1.el6

Comment 16 Fedora Update System 2014-07-20 03:24:52 UTC
mock-1.1.41-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2014-07-22 18:08:12 UTC
mock-1.1.41-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2014-09-16 16:47:10 UTC
mock-1.1.41-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.41-2.fc19

Comment 19 Fedora Update System 2014-09-30 09:00:25 UTC
mock-1.1.41-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.41-3.fc19

Comment 20 Fedora Update System 2014-10-10 16:04:36 UTC
mock-1.1.41-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.