Bug 109972 - diskcheck should also look at inodes
diskcheck should also look at inodes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: diskcheck (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-13 11:09 EST by Karl DeBisschop
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-05 09:04:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
revised diskcheck monitors inodes (10.58 KB, text/plain)
2003-11-17 13:25 EST, Karl DeBisschop
no flags Details

  None (edit)
Description Karl DeBisschop 2003-11-13 11:09:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b)
Gecko/20031110 Firebird/0.7+

Description of problem:
presently only bytes free are checked.

A disk can also become full by running out of inodes.

Checking inodes would be a useful enhancement for diskcheck.

I have a diff for a working replacement that I will provide.

Version-Release number of selected component (if applicable):
1.4-5

How reproducible:
Always

Steps to Reproduce:
1. use up all your inodes and note that diskcheck just doesn't care
    

Actual Results:  disk is no longer writable.

Expected Results:  diskcheck should warn as inodes start running low

Additional info:
Comment 1 Karl DeBisschop 2003-11-17 13:25:09 EST
Created attachment 96021 [details]
revised diskcheck monitors inodes

Since the output of df is parsed the same whether checking inodes or bytes, I
made the old paring section into a function, and called it once for bytes then
again for inodes.

Since this approach reoders the file, the diff tends to obsure rather than
calrify the change. So I'm just posting the revised file instead of the diff
Comment 2 Harald Hoyer 2003-12-05 09:04:18 EST
many thx! :-)

Note You need to log in before you can comment on or make changes to this bug.