Bug 10998 - tcsh bug with [] wildcarding
Summary: tcsh bug with [] wildcarding
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcsh   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-23 08:32 UTC by alain
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 22:54:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description alain 2000-04-23 08:32:37 UTC
(NOTE: I submitted this bug to tcsh-bugs@mx.gw.com today)

% touch abc def ghi ABC DEF GHI
% echo *
ABC abc DEF def GHI ghi
% echo [a-z]*
abc DEF def GHI ghi      <<< DEF and GHI shouldn't show up
% echo [A-Z]*
ABC abc DEF def GHI ghi  <<< abc, def, and ghi shouldn't show up
% echo $tcsh
6.08.00
% uname -a
Linux vaio 2.2.12-20 #1 Mon Sep 27 10:40:35 EDT 1999 i686 unknown
(REDHAT 6.1)

	For what it's worth, I don't see this in older tcsh version
	6.04.00 under Irix.

Comment 1 Anonymous 2000-04-23 08:51:59 UTC
I have 2 redhat linux machines; one running 6.0 and one running 6.1.

I only see the bug in *6.1*, even though both TCSH versions appear to
be identical versions -- these are the output of 'echo $version' from
my tcsh's:

    RedHat 6.1: tcsh 6.08.00 (Astron) 1998-10-02 (i386-intel-linux)
                options 8b,nls,dl,al,rh,color

    RedHat 6.0: tcsh 6.08.00 (Astron) 1998-10-02 (i486-intel-linux)
                options 8b,nls,dl,al,rh,color

Comment 2 Anonymous 2000-04-23 21:36:59 UTC
I've narrowed it down to the LANG stuff, after talking with the tcsh folks.

Basically it's to do with the LANG variables setup by RedHat 6.1's
/etc/csh.login.

If I rename out /etc/csh.login, then invoke a new login, the problem
is corrected. Using the above directory scenario, the results are:

> echo [a-z]*
abc def ghi						<-- looks OK

> setenv LANG "en_US" ; setenv LC_ALL "en_US"; setenv LINGUAS "en_US"
> echo [a-z]*
abc DEF def GHI ghi					<-- now it's BAD

> unsetenv LANG ; unsetenv LC_ALL; unsetenv LINGUAS	<-- unset them
> echo [a-z]*
abc DEF def GHI ghi					<-- still BAD
							    must be cached.

> setenv LANG "" ; setenv LC_ALL ""; setenv LINGUAS ""	<-- set to ""
> echo [a-z]*
abc def ghi						<-- now it's ok again

	It would appear to be a problem with en_US..?

Comment 3 Jeff Johnson 2000-05-15 17:03:59 UTC
This is most probably the "glibc problem with locales". Changing component.

Comment 4 Trond Eivind Glomsrxd 2001-04-18 20:54:55 UTC
It's not a bug, it's a feature in glibc - case doesn't matter for sorting strings.

It would be a bug in tcsh not to handle it slightly different.



Note You need to log in before you can comment on or make changes to this bug.