Bug 1099806 - ncgen test failing on s390x
ncgen test failing on s390x
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hdf (Show other bugs)
rawhide
s390x Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2014-05-21 04:35 EDT by Dan Horák
Modified: 2014-05-22 06:17 EDT (History)
4 users (show)

See Also:
Fixed In Version: hdf-4.2.10-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-22 06:17:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch fixing bug (2.06 KB, patch)
2014-05-22 05:20 EDT, Jakub Čajka
no flags Details | Diff

  None (edit)
Description Dan Horák 2014-05-21 04:35:21 EDT
See below the output of the failing test, looks like a wrong conversion or overflow error

...
make[5]: Entering directory `/builddir/build/BUILD/hdf-4.2.10/mfhdf/ncgen'
============================
Testing testncgen.sh 
============================
testncgen.sh  Test Log
============================
=============================
Running ncgen tests
=============================
testncgen.sh: line 113: [: -ne: unary operator expected
*** test1.cdl	Wed May 21 08:02:54 2014
--- test2.cdl	Wed May 21 08:02:54 2014
***************
*** 50,56 ****
  
   cross =
    4, 5, 0.000244140625,
!   7, 8, 10000000000 ;
  
   i = 10, 20 ;
  
--- 50,56 ----
  
   cross =
    4, 5, 0.000244140625,
!   7, 8, 2147483647 ;
  
   i = 10, 20 ;
  
*** ncgen -b test failed ***
*** ncgen -c test successful ***
=============================
ncgen tests failed: 1
=============================


for full logs please see http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=1403901

Version-Release number of selected component (if applicable):
hdf-4.2.10-1.fc21
Comment 1 Jakub Čajka 2014-05-22 05:20:50 EDT
Created attachment 898297 [details]
Patch fixing bug

Added missing platform check to platform checking. 
Also enabled tests on ppc as they pass (BZ#961007).
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1853490

Note You need to log in before you can comment on or make changes to this bug.