Bug 109982 - evolution-alarm-notify crashes when moving an appointment back
evolution-alarm-notify crashes when moving an appointment back
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
1
All Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
http://bugzilla.ximian.com/show_bug.c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-13 12:45 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-17 14:36:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-11-13 12:45:54 EST
Description of problem:
evolution-alarm-notify crashes when you move an appointment back to a
time where it should have already fired its reminder.

Version-Release number of selected component (if applicable):
1.4.5-7

How reproducible:
Always

Steps to Reproduce:
1. Add an appointment (with a reminder) for some time in the future.
2. Move the appointment back (either by dragging or by editing the
date, doesn't matter which) to a point where the reminder should have
fired.  e.g., move it back to some time yesterday.
3. evolution-alarm-notify crashes.
  
Actual results:
evolution-alarm-notify crashes, and Evolution must be restarted if you
want your appointment reminders to work.

Expected results:
No crash.. it should just accept it and be silent, or probably even
better would be to fire the reminder immediately or after a few
seconds' wait (in case you moved it accidentally, or need to move it
again).

Additional info:
Thanks.
Comment 1 Bart Martens 2004-02-01 07:35:12 EST
Looks like:
http://bugzilla.ximian.com/show_bug.cgi?id=51187

Note You need to log in before you can comment on or make changes to this bug.