Bug 109993 - Drag and drop when you double click an executable text file
Drag and drop when you double click an executable text file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
1
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-13 14:27 EST by Brian
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 10:26:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian 2003-11-13 14:27:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
When I double click to open an executable text file (like a perl
script that I want to edit) in nautilus the cursor turns into the drag
and drop copy cursor (it doesn't matter if I choose "Display" or
"Cancel" from the "Run or Display?" dialog that comes up).  Since I
don't have the mouse button down I have to click somewhere and drop
the file to get the cursor to change back to normal.

I've had this happen with files of type "perl script" and "plain text
document", probably any text file would do.  The file must have the
users execute bit set in the file's permissions.  It doesn't matter
what application I have associated with these file types I still get
the same  bug unless I use nautilus' own text viewer instead of an
external application.  The bug goes away when I remove the execute bit
from the text file.  I've found that this isn't a problem if you try
this from the Desktop, only from within the nautilus program.  I've
also found this isn't a problem if you select the file and press the
'Enter' key to open the file.

Version-Release number of selected component (if applicable):
nautilus-2.4.0-7

How reproducible:
Always

Steps to Reproduce:
1. open nautilus
2. find/create a text file with the execute permission bit set
3. double click the executable text file (assuming you have an
external application like gvim, vi, gedit, etc. associated with this
type of text file)
4. In the "Run or Display?" dialog choose either "Display" or "Cancel"
    

Actual Results:  After step four you begin drag and drop which is not
what should happen when you double click a file.

Expected Results:  Drag and drop should not have started; the cursor
should have remained a normal arrow and the user should not have to
click to conclude the drag and drop operation.

Additional info:
Comment 1 Alexander Larsson 2004-10-04 10:26:18 EDT
Works for me in fc3test3. Seems fixed in Gnome 2.8. 

Note You need to log in before you can comment on or make changes to this bug.