Bug 110011 - "halt -fn" and "halt -f" do not halt the machine
"halt -fn" and "halt -f" do not halt the machine
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Baron
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-13 17:17 EST by Lon Hohberger
Modified: 2013-03-06 00:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-04 21:05:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output of "halt -fn", dmesg, etc. (11.06 KB, text/plain)
2003-11-13 17:21 EST, Lon Hohberger
no flags Details

  None (edit)
Comment 1 Lon Hohberger 2003-11-13 17:20:15 EST
Description: Running "halt -fn" or "halt -f" doesn't halt the machine
as expected.

Version-Release: 2.4.9-e.27
How reproducible: 100%
Steps to Reproduce: Run "halt -fn"
Actual results: Machine running; no processes affected.
Expected results: Halted machine.
Comment 2 Lon Hohberger 2003-11-13 17:21:31 EST
Created attachment 95959 [details]
strace output of "halt -fn", dmesg, etc.

Attaching dmesg / strace output.
Comment 3 Jason Baron 2003-12-04 11:13:16 EST
As some more info, this behavior is not specific to RHEL 2.1.
Apparently on a 'halt -fn', a SIGTSTP is sent to process 1, or 'init'.
Also a HALT flag is passed to the reboot syscall. That syscall doesn't
do anything in practice on the x86 architecture. Thus, any differences
in 'halt -fn' behavior would appear to be non-kernel related. My
thought on this is that halting 'init' is probably possible of
creating unpredictable system-wide consequences. The manpage for halt
isn't specific enough in the -f case, to suggest to me that this
behavior is inconsistent with the manpage. Thus, i would suggest
closing this as not a bug.
Comment 4 Tim Burke 2004-01-04 21:05:50 EST
Any benefit to updating the manpage accordingly?

Note You need to log in before you can comment on or make changes to this bug.