Bug 1100201 - [ ERROR ] Failed to execute stage 'Environment customization': Package rollback information is unavailable
Summary: [ ERROR ] Failed to execute stage 'Environment customization': Package rollba...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Lev Veyde
QA Contact: Gonza
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-22 09:02 UTC by Nikolai Sednev
Modified: 2019-07-16 11:30 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
When updating the Manager, any package that cannot be rolled back to a previous version is now listed in detail so the user can better evaluate whether to proceed.
Clone Of:
Environment:
Last Closed: 2016-03-09 20:46:11 UTC
oVirt Team: Integration


Attachments (Terms of Use)
logs (17.16 KB, application/x-gzip)
2014-05-22 09:02 UTC, Nikolai Sednev
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 43748 None NEW packaging: setup: display unreinstallable packages Never

Description Nikolai Sednev 2014-05-22 09:02:39 UTC
Created attachment 898284 [details]
logs

Description of problem:
After rhevm av9.1 was updated to av9.2 and rhevm-setup was initiated for the upgrade procedure, I've received the error as described bellow and upgrade failed:

Updated:
  rhev-guest-tools-iso.noarch 0:3.4-5.el6ev                     rhevm-lib.noarch 0:3.4.0-0.21.el6ev                              
  rhevm-setup.noarch 0:3.4.0-0.21.el6ev                         rhevm-setup-base.noarch 0:3.4.0-0.21.el6ev                       
  rhevm-setup-plugin-ovirt-engine.noarch 0:3.4.0-0.21.el6ev     rhevm-setup-plugin-ovirt-engine-common.noarch 0:3.4.0-0.21.el6ev 
  rhevm-setup-plugin-websocket-proxy.noarch 0:3.4.0-0.21.el6ev  rhevm-setup-plugins.noarch 0:3.4.0-2.el6ev                       
  rhevm-websocket-proxy.noarch 0:3.4.0-0.21.el6ev                                                                                

Complete!
[root@dhcp163-99 ~]# rhevm-setup 
[ INFO  ] Stage: Initializing    
[ INFO  ] Stage: Environment setup
          Configuration files: ['/etc/ovirt-engine-setup.conf.d/10-packaging.conf', '/etc/ovirt-engine-setup.conf.d/20-setup-ovirt-post.conf']
          Log file: /var/log/ovirt-engine/setup/ovirt-engine-setup-20140522112102-ie5vld.log
          Version: otopi-1.2.1 (otopi-1.2.1-1.el6ev)
[ INFO  ] Stage: Environment packages setup
[ INFO  ] Stage: Programs detection
[ INFO  ] Stage: Environment setup
[ INFO  ] Stage: Environment customization

          Welcome to the RHEV 3.4 upgrade.
          Please read the RHEV 3.4 install guide
          https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.4/html/Installation_Guide/index.html
          and the RHEV 3.4 Upgrade Guide: Tips, Considerations and Roll-back Issues article
          https://access.redhat.com/site/articles/882773
          before proceeding with the upgrade.
          Would you like to continue with the upgrade? (Yes, No) [Yes]:

          --== PRODUCT OPTIONS ==--


          --== PACKAGES ==--

[ INFO  ] Checking for product updates...
          Setup has found updates for some packages, do you wish to update them now? (Yes, No) [Yes]:
[ INFO  ] Checking for an update for Setup...
          Setup will not be able to rollback new packages in case of a failure, because installed ones were not found in enabled repositories.
          Do you want to abort Setup? (Yes, No) [Yes]:
[ ERROR ] Failed to execute stage 'Environment customization': Package rollback information is unavailable
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20140522112102-ie5vld.log
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20140522112213-setup.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed
[root@dhcp163-99 ~]#



Version-Release number of selected component (if applicable):
rhevm-3.4.0-0.20.el6ev.noarch

How reproducible:
100% at guest VM dhcp163-99.scl.lab.tlv.redhat.com

Steps to Reproduce:
1.yum update all -y
2.rhevm-setup

Actual results:
Execution of setup failed
[ ERROR ] Failed to execute stage 'Environment customization': Package rollback information is unavailable


Expected results:
rhevm-setup should upgrade the engine successfully

Additional info:
some logs attached

Comment 1 Yedidyah Bar David 2014-05-25 08:50:05 UTC
(In reply to Nikolai Sednev from comment #0)
> Created attachment 898284 [details]
> logs
> 
> Description of problem:
> After rhevm av9.1 was updated to av9.2 and rhevm-setup was initiated for the
> upgrade procedure, I've received the error as described bellow and upgrade
> failed:
> 
> Updated:
>   rhev-guest-tools-iso.noarch 0:3.4-5.el6ev                    
> rhevm-lib.noarch 0:3.4.0-0.21.el6ev                              
>   rhevm-setup.noarch 0:3.4.0-0.21.el6ev                        
> rhevm-setup-base.noarch 0:3.4.0-0.21.el6ev                       
>   rhevm-setup-plugin-ovirt-engine.noarch 0:3.4.0-0.21.el6ev    
> rhevm-setup-plugin-ovirt-engine-common.noarch 0:3.4.0-0.21.el6ev 
>   rhevm-setup-plugin-websocket-proxy.noarch 0:3.4.0-0.21.el6ev 
> rhevm-setup-plugins.noarch 0:3.4.0-2.el6ev                       
>   rhevm-websocket-proxy.noarch 0:3.4.0-0.21.el6ev                           
> 
> 
> Complete!
> [root@dhcp163-99 ~]# rhevm-setup 
> [ INFO  ] Stage: Initializing    
> [ INFO  ] Stage: Environment setup
>           Configuration files:
> ['/etc/ovirt-engine-setup.conf.d/10-packaging.conf',
> '/etc/ovirt-engine-setup.conf.d/20-setup-ovirt-post.conf']
>           Log file:
> /var/log/ovirt-engine/setup/ovirt-engine-setup-20140522112102-ie5vld.log
>           Version: otopi-1.2.1 (otopi-1.2.1-1.el6ev)
> [ INFO  ] Stage: Environment packages setup
> [ INFO  ] Stage: Programs detection
> [ INFO  ] Stage: Environment setup
> [ INFO  ] Stage: Environment customization
> 
>           Welcome to the RHEV 3.4 upgrade.
>           Please read the RHEV 3.4 install guide
>          
> https://access.redhat.com/site/documentation/en-US/
> Red_Hat_Enterprise_Virtualization/3.4/html/Installation_Guide/index.html
>           and the RHEV 3.4 Upgrade Guide: Tips, Considerations and Roll-back
> Issues article
>           https://access.redhat.com/site/articles/882773
>           before proceeding with the upgrade.
>           Would you like to continue with the upgrade? (Yes, No) [Yes]:
> 
>           --== PRODUCT OPTIONS ==--
> 
> 
>           --== PACKAGES ==--
> 
> [ INFO  ] Checking for product updates...
>           Setup has found updates for some packages, do you wish to update
> them now? (Yes, No) [Yes]:
> [ INFO  ] Checking for an update for Setup...
>           Setup will not be able to rollback new packages in case of a
> failure, because installed ones were not found in enabled repositories.
>           Do you want to abort Setup? (Yes, No) [Yes]:

Note that you were asked here something, and accepted the default 'Yes' which aborts setup.

> [ ERROR ] Failed to execute stage 'Environment customization': Package
> rollback information is unavailable
> [ INFO  ] Stage: Clean up
>           Log file is located at
> /var/log/ovirt-engine/setup/ovirt-engine-setup-20140522112102-ie5vld.log
> [ INFO  ] Generating answer file
> '/var/lib/ovirt-engine/setup/answers/20140522112213-setup.conf'
> [ INFO  ] Stage: Pre-termination
> [ INFO  ] Stage: Termination
> [ ERROR ] Execution of setup failed
> [root@dhcp163-99 ~]#
> 
> 
> 
> Version-Release number of selected component (if applicable):
> rhevm-3.4.0-0.20.el6ev.noarch
> 
> How reproducible:
> 100% at guest VM dhcp163-99.scl.lab.tlv.redhat.com
> 
> Steps to Reproduce:
> 1.yum update all -y
> 2.rhevm-setup
> 
> Actual results:
> Execution of setup failed
> [ ERROR ] Failed to execute stage 'Environment customization': Package
> rollback information is unavailable
> 
> 
> Expected results:
> rhevm-setup should upgrade the engine successfully

If these are the "expected results", you should simply reply 'No' up above.

> 
> Additional info:
> some logs attached

If you imply there is some other bug, please better explain what it is.

Note that there might have been some local issue regarding this specific upgrade (e.g. it makes sense that you somehow disabled the av9.1 repo, or it was unavailable for some other reason, whatever). If you want to discuss this specific issue, please provide more details. Otherwise, you can try upgrading from an earlier version (e.g. av8 etc).

Comment 2 Yedidyah Bar David 2014-05-25 09:43:13 UTC
Closing for now. Please reopen if still relevant. Thanks!

Comment 3 Nikolai Sednev 2014-05-25 10:52:55 UTC
(In reply to Yedidyah Bar David from comment #1)
> (In reply to Nikolai Sednev from comment #0)
> > Created attachment 898284 [details]
> > logs
> > 
> > Description of problem:
> > After rhevm av9.1 was updated to av9.2 and rhevm-setup was initiated for the
> > upgrade procedure, I've received the error as described bellow and upgrade
> > failed:
> > 
> > Updated:
> >   rhev-guest-tools-iso.noarch 0:3.4-5.el6ev                    
> > rhevm-lib.noarch 0:3.4.0-0.21.el6ev                              
> >   rhevm-setup.noarch 0:3.4.0-0.21.el6ev                        
> > rhevm-setup-base.noarch 0:3.4.0-0.21.el6ev                       
> >   rhevm-setup-plugin-ovirt-engine.noarch 0:3.4.0-0.21.el6ev    
> > rhevm-setup-plugin-ovirt-engine-common.noarch 0:3.4.0-0.21.el6ev 
> >   rhevm-setup-plugin-websocket-proxy.noarch 0:3.4.0-0.21.el6ev 
> > rhevm-setup-plugins.noarch 0:3.4.0-2.el6ev                       
> >   rhevm-websocket-proxy.noarch 0:3.4.0-0.21.el6ev                           
> > 
> > 
> > Complete!
> > [root@dhcp163-99 ~]# rhevm-setup 
> > [ INFO  ] Stage: Initializing    
> > [ INFO  ] Stage: Environment setup
> >           Configuration files:
> > ['/etc/ovirt-engine-setup.conf.d/10-packaging.conf',
> > '/etc/ovirt-engine-setup.conf.d/20-setup-ovirt-post.conf']
> >           Log file:
> > /var/log/ovirt-engine/setup/ovirt-engine-setup-20140522112102-ie5vld.log
> >           Version: otopi-1.2.1 (otopi-1.2.1-1.el6ev)
> > [ INFO  ] Stage: Environment packages setup
> > [ INFO  ] Stage: Programs detection
> > [ INFO  ] Stage: Environment setup
> > [ INFO  ] Stage: Environment customization
> > 
> >           Welcome to the RHEV 3.4 upgrade.
> >           Please read the RHEV 3.4 install guide
> >          
> > https://access.redhat.com/site/documentation/en-US/
> > Red_Hat_Enterprise_Virtualization/3.4/html/Installation_Guide/index.html
> >           and the RHEV 3.4 Upgrade Guide: Tips, Considerations and Roll-back
> > Issues article
> >           https://access.redhat.com/site/articles/882773
> >           before proceeding with the upgrade.
> >           Would you like to continue with the upgrade? (Yes, No) [Yes]:
> > 
> >           --== PRODUCT OPTIONS ==--
> > 
> > 
> >           --== PACKAGES ==--
> > 
> > [ INFO  ] Checking for product updates...
> >           Setup has found updates for some packages, do you wish to update
> > them now? (Yes, No) [Yes]:
> > [ INFO  ] Checking for an update for Setup...
> >           Setup will not be able to rollback new packages in case of a
> > failure, because installed ones were not found in enabled repositories.
> >           Do you want to abort Setup? (Yes, No) [Yes]:
> 
> Note that you were asked here something, and accepted the default 'Yes'
> which aborts setup.
> 
> > [ ERROR ] Failed to execute stage 'Environment customization': Package
> > rollback information is unavailable
> > [ INFO  ] Stage: Clean up
> >           Log file is located at
> > /var/log/ovirt-engine/setup/ovirt-engine-setup-20140522112102-ie5vld.log
> > [ INFO  ] Generating answer file
> > '/var/lib/ovirt-engine/setup/answers/20140522112213-setup.conf'
> > [ INFO  ] Stage: Pre-termination
> > [ INFO  ] Stage: Termination
> > [ ERROR ] Execution of setup failed
> > [root@dhcp163-99 ~]#
> > 
> > 
> > 
> > Version-Release number of selected component (if applicable):
> > rhevm-3.4.0-0.20.el6ev.noarch

> > 
> > How reproducible:
> > 100% at guest VM dhcp163-99.scl.lab.tlv.redhat.com
> > 
> > Steps to Reproduce:
> > 1.yum update all -y
> > 2.rhevm-setup
> > 
> > Actual results:
> > Execution of setup failed
> > [ ERROR ] Failed to execute stage 'Environment customization': Package
> > rollback information is unavailable
> > 
> > 
> > Expected results:
> > rhevm-setup should upgrade the engine successfully
> 
> If these are the "expected results", you should simply reply 'No' up above.
> 
> > 
> > Additional info:
> > some logs attached
> 
> If you imply there is some other bug, please better explain what it is.
> 
> Note that there might have been some local issue regarding this specific
> upgrade (e.g. it makes sense that you somehow disabled the av9.1 repo, or it
> was unavailable for some other reason, whatever). If you want to discuss
> this specific issue, please provide more details. Otherwise, you can try
> upgrading from an earlier version (e.g. av8 etc).

You're absolutely correct, my bad, found the mistake and worked for me now OK!
Sorry for inconvenience. 
I should have answer here "no"
[ INFO  ] Checking for an update for Setup...
          Setup will not be able to rollback new packages in case of a failure, because installed ones were not found in enabled repositories.
          Do you want to abort Setup? (Yes, No) [Yes]:

Comment 4 Nikolai Sednev 2014-09-01 11:15:01 UTC
Unable to reproduce, please close.

Comment 8 Yedidyah Bar David 2015-07-16 14:19:59 UTC
Perhaps we can show which packages are not reinstallable.

Comment 9 Sandro Bonazzola 2015-08-05 12:05:42 UTC
(In reply to Yedidyah Bar David from comment #8)
> Perhaps we can show which packages are not reinstallable.

Reopened, we'll show which packages are not reinstallable.
Reducing severity accordingly.

Comment 10 Yedidyah Bar David 2015-08-16 09:05:19 UTC
Note to QE:

Please check various update/upgrade scenarios due to a slightly changed logic in the code that determines if the updated packages are available.

Comment 15 Gonza 2016-01-06 15:06:31 UTC
Verified with upgrade from:
ovirt-engine-3.5.7.1-0.0.master.20151220162429.git1e35eec.el6.noarch
to:
ovirt-engine-3.6.3-0.0.master.20160105173810.git7421257.el6.noarch

Setup will not be able to rollback new packages in case of a failure, because the following installed packages were not found in enabled repositories:
ovirt-engine-dbscripts-3.5.7.1-0.0.master.20151220162429.git1e35eec.el6.noarch
ovirt-engine-restapi-3.5.7.1-0.0.master.20151220162429.git1e35eec.el6.noarch
ovirt-engine-extensions-api-impl-3.5.7.1-0.0.master.20151220162429.git1e35eec.el6.noarch
ovirt-engine-tools-3.5.7.1-0.0.master.20151220162429.git1e35eec.el6.noarch
ovirt-engine-userportal-3.5.7.1-0.0.master.20151220162429.git1e35eec.el6.noarch
ovirt-engine-websocket-proxy-3.5.7.1-0.0.master.20151220162429.git1e35eec.el6.noarch
ovirt-engine-3.5.7.1-0.0.master.20151220162429.git1e35eec.el6.noarch
ovirt-engine-backend-3.5.7.1-0.0.master.20151220162429.git1e35eec.el6.noarch
ovirt-engine-webadmin-portal-3.5.7.1-0.0.master.20151220162429.git1e35eec.el6.noarch

Comment 17 errata-xmlrpc 2016-03-09 20:46:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.