Bug 1100230 - Unowned dir /usr/share/langtable
Summary: Unowned dir /usr/share/langtable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: langtable
Version: 19
Hardware: All
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Mike FABIAN
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-22 10:34 UTC by Ralf Corsepius
Modified: 2014-06-10 03:10 UTC (History)
3 users (show)

Fixed In Version: langtable-0.0.24-2.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-05 04:24:17 UTC


Attachments (Terms of Use)

Description Ralf Corsepius 2014-05-22 10:34:29 UTC
Description of problem:

The directory /usr/share/langtable is unowned.

Version-Release number of selected component (if applicable):
langtable-0.0.24-1 on all f19, f20 and rawhide

How reproducible:
Always

Steps to Reproduce:
1. yum install langtable-data
2. rpm -qf /usr/share/langtable

Actual results:
# rpm -qf /usr/share/langtable
file /usr/share/langtable is not owned by any package

Expected results:
/usr/share/langtable to be owned

Additional info:
- Technically, it would be sufficient to let langtable own this directory, however, I recommend to let both langtable and langtable-data own /usr/share/langtable.
- As I consider this issue to be obvious and minor, I am inclined to apply my provenpackager privileges to resolve this issue.

Comment 1 Fedora Update System 2014-05-22 14:34:40 UTC
langtable-0.0.24-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/langtable-0.0.24-2.fc19

Comment 2 Fedora Update System 2014-05-22 14:39:19 UTC
langtable-0.0.24-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/langtable-0.0.24-2.fc20

Comment 3 Fedora Update System 2014-05-23 18:57:09 UTC
Package langtable-0.0.24-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing langtable-0.0.24-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6613/langtable-0.0.24-2.fc19
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2014-06-05 04:24:17 UTC
langtable-0.0.24-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Adam Williamson 2014-06-06 00:21:57 UTC
ralf, why do you recommend having both packages own the directory? as langtable-data requires langtable, just having langtable own it ought to be entirely sufficient (and arguably having both own it is excessive).

Comment 6 Ralf Corsepius 2014-06-06 02:49:12 UTC
(In reply to Adam Williamson from comment #5)
> ralf, why do you recommend having both packages own the directory? as
> langtable-data requires langtable, just having langtable own it ought to be
> entirely sufficient (and arguably having both own it is excessive).
cf. my initial posting/comment #1.

There I said, it's "technically sufficient to let langtable own this directory". The rationale for this is exactly what you say: Langtable-data already requires langtable.

In general, I am however recommending "multiple ownership", because this assures directory stay owned rpm-wise, when package hierarchies change or when there is no strictly hierarchical package dependency (aka. "plugins").

Comment 7 Fedora Update System 2014-06-10 03:10:43 UTC
langtable-0.0.24-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.