Bug 11003 - util-linux BuildPreReq missing.
Summary: util-linux BuildPreReq missing.
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-23 19:04 UTC by Pekka Savola
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-14 14:18:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2000-04-23 19:04:23 UTC
After the addition of rawIO patch, you couldn't rebuild util-linux*.src.rpm
with vanilla Linux kernel.

BuildPreReq: kernel >= 2.2.12-7 would probably fix this.

Comment 1 Jeff Johnson 2000-05-14 14:18:59 UTC
Adding an open ended dependency like this, while it might work in this case,
is not the Right Thing To Do because it makes a claim that the util-linux
src rpm will build with all future kernel versions, which is untestable at
best. What is really needed is explicit (rather than implicit) dependencies
on, for example, RawIO rather than kernel, but that will take a larger
administrative structure and better dependency analysis tools than we have
today.


Note You need to log in before you can comment on or make changes to this bug.