Bug 110035 - Erratic behaviour of kudzu and mouse
Erratic behaviour of kudzu and mouse
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-14 05:58 EST by antonio montagnani
Modified: 2014-03-16 22:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 13:54:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description antonio montagnani 2003-11-14 05:58:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.4.1)
Gecko/20031030

Description of problem:
when I start kudzu in a terminal window, my wheel mouse becomes
erratic and I lose its control, many windows open in the graphical window.
Furthermore, in the window, kudzu start in the window after a while
and says that mouse has been removed, asking if I want to remove/keep
modifications.
I have to log out by Ctrl-Alt-Backspace

Version-Release number of selected component (if applicable):
kudzu 1.1.36-1

How reproducible:
Always

Steps to Reproduce:
1.Open a Terminal Window
2.become su
3.start kudzu
    

Actual Results:  1) Lost of control of my Wheelmouse
2) Crazy behaviour of kudzu that start by itself
3) kudzu tries to remove my mouse from configuration

Expected Results:  Kudzu should start and let me probe my Soundcard
(as in RedHat9 working till last night)

Additional info:

I get a message at shut-down saying that mouse service fails: I do not
know if connected.
Comment 1 antonio montagnani 2003-11-14 06:19:20 EST
I switched to a text window by Ctrl-Alt-F1, I logged as a different
user, I became su, I typed /usr/sbin/kudzu, but kudzu doesn't pop up
and I go back to the command line, with no action.

Very disappointing as I cannot setup old Soundblaster, that was fine
in RedHat9 through kudzu.
Comment 2 Bill Nottingham 2003-11-14 11:27:54 EST
kudzu really shouldn't be run under X, especially in the presence of a
PS/2 mouse. You can run it with '-s' to skip the mouse probe.
Comment 3 Bart Martens 2003-12-21 07:52:48 EST
I ran "kudzu -p" under X. Since the man page says "Print probe
information to the screen, and do not actually  configure or
unconfigure any devices" about the -p option, I thought this was safe
under X. It isn't. The PS/2 wheel mouse is correctly detected, but
after running "kudzu -p" some ghost makes the mouse pointer jump
around and click like crazy; it even tried to do a shutdown.

I suggest a warning in the man page for the -p option, or a safer
behaviour of "kudzu -p".

Comment 4 David Juran 2004-01-28 18:38:23 EST
Here are some observations that I think are related.
On my Compaq Armada M700 running RHEL 3 (kudzu-1.1.22-1.1) I have a
built-in keypad and also a mouse that  plugs into the PS/2 port. I
don't know what type of mouse this external mouse is, but on it the
words Dell by Microsoft are written and also PN X06-08477 Product ID
63618-OEM-
Now if this mouse is plugged in while starting the computer I get the
following entry into /etc/sysconfig/hwconf

class: MOUSE
bus: PSAUX
detached: 0
device: psaux
driver: msintellips/2
desc: "Generic PS/2 Wheel Mouse"

And this is very wrong, neither theinternal nor the external mouse works.
Now if the external mouse is _not_ plugged in while starting the
computer the entry looks like this:

class: MOUSE
bus: PSAUX
detached: 0
device: psaux
driver: genericps/2
desc: "Generic Mouse (PS/2)"

Now I the internal pad works fine, and if I now plug in the external
mouse it works fine as well. So my conclusion is that kudzu for some
reason misinterprets this mouse as intelimouse although it really is a
generic PS/2
Comment 5 Bill Nottingham 2005-04-28 13:54:57 EDT
This is fixed with FC2 and later releases.

Note You need to log in before you can comment on or make changes to this bug.