Bug 110037 - Won't start at all
Won't start at all
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: yum (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-14 06:12 EST by Daniel Malmgren
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-21 08:34:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Malmgren 2003-11-14 06:12:34 EST
Description of problem:
Yum refuses to start at all.

Version-Release number of selected component (if applicable):
2.0.4-3

How reproducible:
100%

Actual results:
[~#] yum update
Traceback (most recent call last):
  File "/usr/bin/yum", line 22, in ?
    import yummain
ImportError: Bad magic number in /usr/share/yum/yummain.pyc

Additional info:
2.0.4-2 works perfect.
It doesn't seem to matter what arguments I give, I get the same result
anyway.
Comment 1 Jeff Johnson 2003-11-21 08:03:51 EST
Hmmm, this smells like python-2.3.2.

What happens if you rename the *.pyc file, causing python to
recompile from the *.py?
Comment 2 Daniel Malmgren 2003-11-21 08:34:17 EST
On the opposite, it seems that this was a problem from running python
2.2.3. Upgrading pythong to 2.3.2 seems to have fixed it.

The reason for not upgrading python in the first place was that it
broke some dependencies. Hope this will be fixed too.

Well, yum works now. I'm closing this bug, marking it as NOTABUG. I
guess the dependencies of yum are wrong though if it needs python 2.3.2...

Note You need to log in before you can comment on or make changes to this bug.