Bug 1100533 - Missing 'user-cancel' documentation in guestfish(1)
Summary: Missing 'user-cancel' documentation in guestfish(1)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libguestfs
Version: 6.5
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: rc
: ---
Assignee: Pino Toscano
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-23 03:25 UTC by Lingfei Kong
Modified: 2015-07-22 05:55 UTC (History)
7 users (show)

Fixed In Version: libguestfs-1.20.11-13.el6
Doc Type: Bug Fix
Doc Text:
Minor fixes and improvements have been done to the help message of the "set-append" command, an error message of the "guestfish umount" command, and to the guestfish(1) and virt-edit(1) man pages.
Clone Of:
Environment:
Last Closed: 2015-07-22 05:55:22 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1444 normal SHIPPED_LIVE libguestfs bug fix and enhancement update 2015-07-20 18:44:02 UTC

Description Lingfei Kong 2014-05-23 03:25:42 UTC
Description of problem:
When I read guestfish(1), I can find the following line:
Guestfish sets this flag to true when used interactively, so that "^C" can cancel long-running commands gracefully (see "user-cancel").
but i can not find the 'user-cancel' section in guestfish(1)

In fact in rhel6's guestfish there is no 'user-cancle' API, but i can find the 'user-cancle' API in rhel7's guestfish tool

Version-Release number of selected component (if applicable):
libguestfs-1.20.11-3.el6

How reproducible:
100%

Steps to Reproduce:
#man 1 guestfish

Actual results:
Can find the following line:
Guestfish sets this flag to true when used interactively, so that "^C" can cancel long-running commands gracefully (see "user-cancel").
And can not find the 'user-cancel' section

Expected results:
API name "user-cancel" should not be in guestfish(1) of rhel6

Additional info:

Comment 3 Pino Toscano 2015-01-20 13:49:33 UTC
(In reply to Lingfei Kong from comment #0)
> When I read guestfish(1), I can find the following line:
> Guestfish sets this flag to true when used interactively, so that "^C" can
> cancel long-running commands gracefully (see "user-cancel").
> but i can not find the 'user-cancel' section in guestfish(1)
> 
> In fact in rhel6's guestfish there is no 'user-cancle' API, but i can find
> the 'user-cancle' API in rhel7's guestfish tool

Actually, 'user-cancel' exists also in RHEL 6, but since it was implemented manually (and not generated using our API generator) it had no documentation associated.
The right fix here is backport the upstream change to make 'user-cancel' automatically generated, so documented as well.

Forgot to change this bug earlier, sorry, changing it now to reflect the actual fixes.

Comment 4 Hu Zhang 2015-03-10 08:32:05 UTC
Verified with the package version:
libguestfs-1.20.11-14.el6.x86_64

Verify steps:
#man guestfish

'user-cancel' section is added in guestfish(1) as below.

user-cancel
        user-cancel

       This function cancels the current upload or download operation.
...

So verified.

Comment 7 errata-xmlrpc 2015-07-22 05:55:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1444.html


Note You need to log in before you can comment on or make changes to this bug.