Bug 1100831 - Add Resource button disappears after selecting a VM resource
Summary: Add Resource button disappears after selecting a VM resource
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci
Version: 6.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Ryan McCabe
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-23 14:31 UTC by Radek Steiger
Modified: 2015-07-22 07:33 UTC (History)
2 users (show)

Fixed In Version: luci-0.26.0-65.el6
Doc Type: Bug Fix
Doc Text:
Cause: Previously, luci did not allow VM resources to have children. After adding a VM to a service group, the "add resource" button was removed so that no further resources could be added. Support for handling configurations that contain resources with children has been added to the GUI, however. Consequence: Even though luci supported configurations where service groups contained VM resources and additioanl resources, the "add resource" button was removed after adding a VM resource. Fix: The "add resource" button is no longer removed when adding a VM resource to a service group. Result: Users are now able to use luci to add additional resources to service groups containing VM resources.
Clone Of:
Environment:
Last Closed: 2015-07-22 07:33:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1454 normal SHIPPED_LIVE luci bug fix and enhancement update 2015-07-20 18:43:43 UTC
Red Hat Bugzilla 1100280 None None None Never
Red Hat Bugzilla 1100817 None None None Never

Internal Links: 1100280 1100817

Description Radek Steiger 2014-05-23 14:31:37 UTC
Description of problem:

When creating a new service group under the Service Groups tab, selection "Virtual Machine" resource will cause the Add Resource button to disappear. This might have been intentional at first, since an attempt to add a VM resource with an existing resource will return an error message "VMs may have no children and may not be children of other resources". 

However, the Add Resource button doesn't show up again when the VM resource is removed from the form and a full page reload is needed to get it back. 



Version-Release number of selected component (if applicable):

luci-0.26.0-48.el6.x86_64


How reproducible:

Always


Steps to Reproduce:
1. Open Service Groups tab in luci
2. Open the form by clicking Add
3. Click Add Resource
4. Select Virtual Machine from the drop-down menu
5. Click Remove button in the resource part header


Actual results:

Add Resource button is not present on the form anymore so the user is unable select a different resource


Expected results:

Add Resource button is present and can be used to add a different resource

Comment 6 errata-xmlrpc 2015-07-22 07:33:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1454.html


Note You need to log in before you can comment on or make changes to this bug.