Bug 110092 - iostat and /proc/stat stopped reporting disk io stats
iostat and /proc/stat stopped reporting disk io stats
Status: CLOSED DUPLICATE of bug 109799
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-14 14:30 EST by Ulf Zimmermann
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulf Zimmermann 2003-11-14 14:30:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4)
Gecko/20030624 Netscape/7.1 (ax)

Description of problem:
HP/Compaq 5i Raid controller via cciss driver

Under kernel e.25 iostat without any options and /proc/stat reports
disk io activities. Kernel e.27 breaks this behavios, returning no
disk devices via /proc/stat and forces you to use iostat -x <device
name>. This breaks many reporting/monitoring tools.


Version-Release number of selected component (if applicable):
kernel e.27 smp/enterprise

How reproducible:
Always

Steps to Reproduce:
1. cat /proc/stat | grep disk_io
2. iostat


Actual Results:  dbdw ulf /home/ulf > cat /proc/stat | grep disk_io
disk_io: 
dbdw ulf /home/ulf > iostat 
Linux 2.4.9-e.27smp (dbdw.autc.com)     11/14/2003

avg-cpu:  %user   %nice    %sys   %idle
           1.28    0.16    0.37   98.18

Device:        tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn


Expected Results:  dbrac-01 ulf /home/ulf > cat /proc/stat | grep disk_io
disk_io: (8,0):(8649272,4334321,109951450,4314951,25881846)
(8,1):(149933448,89639727,1904556409,60293721,1421939631)
(8,2):(16078475,9639371,234015576,6439104,58390020)
(8,3):(115229339,63207878,1272929176,52021461,1264552234)
(8,4):(12212193,3219863,192982128,8992330,744823446)
(8,5):(8,8,16,0,0) (8,6):(35454538,17527387,365243778,17927151,365297260) 
dbrac-01 ulf /home/ulf > iostat
Linux 2.4.9-e.25enterprise (dbrac-01)   11/14/2003

avg-cpu:  %user   %nice    %sys   %idle
           8.43    0.62    2.72   88.23

Device:        tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
dev8-0        4.60        58.50        13.77  109951558   25881873
dev8-1       79.77      1013.32       756.55 1904556581 1421939688
dev8-2        8.55       124.51        31.07  234015748   58390057
dev8-3       61.31       677.27       672.81 1272929348 1264552271
dev8-4        6.50       102.68       396.29  192982128  744823542
dev8-5        0.00         0.00         0.00         16          0
dev8-6       18.86       194.33       194.36  365244046  365297388


Additional info:

cciss driver is 2.4.45 in both kernels.
Comment 1 Ulf Zimmermann 2003-11-14 15:28:07 EST
Talking to jp at Redhat, the above output of the e.25 kernel system is
only showing the fibre channel attached storage, not the cciss device.
/proc/stat is not showing anything as its define to stop at major
number 99 and cciss uses higher major numbers, in this case 104.
Comment 2 Donnie Webb 2004-01-08 15:45:51 EST
I am having the same problem on a Compaq/HP DL 380 with cciss drivers 
on kernels e12, e16, e25 and e35.  No data returned from iostat -d.  
An iostat -x will return other data that I am not needing.  This 
appears on 7.3 as well.  Versions of sysstat tested include 4.0.1, 
4.0.3, 4.0.7 and 5.0.1.  The disk_io: line in  /proc/stat is blank if 
that makes any difference.

Donnie Webb
Comment 3 Neil Horman 2004-05-05 11:20:22 EDT
This is a dup of bug 109799

*** This bug has been marked as a duplicate of 109799 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:00:00 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.