Bug 1100946 - dnf install <bin filename> installs both i686 and x86_64 packages for no reason
Summary: dnf install <bin filename> installs both i686 and x86_64 packages for no reason
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: 20
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Honza Silhan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1147034 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-24 07:09 UTC by Dan Callaghan
Modified: 2014-09-29 12:05 UTC (History)
7 users (show)

Fixed In Version: dnf-0.5.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-29 07:20:17 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Callaghan 2014-05-24 07:09:07 UTC
Description of problem:
When installing a package by filename, dnf installs both i686 and x86_64 packages if the filename in question is a colored binary.

Version-Release number of selected component (if applicable):
dnf-0.4.20-1.fc20

How reproducible:
easily

Steps to Reproduce:
1. dnf install /usr/bin/qmake-qt4

Actual results:
Attempts to install qt-devel.i686 and qt-devel.x86_64

Expected results:
Both packages provide the file but due to coloring only qt-devel.x86_64's copy will actually end up on my filesystem, so that's the only one I want to install.

Additional info:
Yum gets this right. yum install /usr/bin/qmake-qt4 only picks qt-devel.x86_64.

Comment 1 Ales Kozumplik 2014-05-26 06:27:12 UTC
Hello Dan and thanks for the report, we'll take a look.

Comment 2 Simon Gerhards 2014-06-01 14:27:52 UTC
Hi,

As part of the discussion of bug #1054909 Jan Silhan pointed me to this bug.

I see this behaviour upon installing wine.i686. Notice the differences betweeen yum and dnf in the following outputs:

yum:
"""
================================================================================
 Package                      Arch       Version              Repository   Size
================================================================================
Installing:
 wine                         i686       1.7.18-1.fc20        updates      44 k
Installing for dependencies:
 gd                           i686       2.1.0-3.fc20         fedora      136 k
 iniparser                    x86_64     3.1-3.fc20           fedora       13 k
 libXpm                       i686       3.5.10-5.fc20        fedora       52 k
 libgphoto2                   i686       2.5.3-6.fc20         updates     1.2 M
 libusbx                      i686       1.0.18-1.fc20        updates      59 k
 libvpx                       i686       1.3.0-4.fc20         updates     512 k
 mingw32-wine-gecko           noarch     2.24-1.fc20          fedora       21 M
 nss-mdns                     i686       0.10-13.fc20         fedora       29 k
 samba-winbind                x86_64     2:4.1.6-1.fc20       updates     445 k
 samba-winbind-clients        x86_64     2:4.1.6-1.fc20       updates     112 k
 samba-winbind-modules        x86_64     2:4.1.6-1.fc20       updates      92 k
 wine-alsa                    i686       1.7.18-1.fc20        updates      92 k
 wine-capi                    i686       1.7.18-1.fc20        updates      50 k
 wine-cms                     i686       1.7.18-1.fc20        updates      65 k
 wine-common                  noarch     1.7.18-1.fc20        updates      98 k
 wine-core                    i686       1.7.18-1.fc20        updates      19 M
 wine-courier-fonts           noarch     1.7.18-1.fc20        updates      58 k
 wine-desktop                 x86_64     1.7.18-1.fc20        updates     147 k
 wine-filesystem              noarch     1.7.18-1.fc20        updates      72 k
 wine-fixedsys-fonts          noarch     1.7.18-1.fc20        updates      57 k
 wine-fonts                   noarch     1.7.18-1.fc20        updates      44 k
 wine-ldap                    i686       1.7.18-1.fc20        updates     115 k
 wine-marlett-fonts           noarch     1.7.18-1.fc20        updates      56 k
 wine-mono                    noarch     4.5.2-1.fc20         updates      51 M
 wine-ms-sans-serif-fonts     noarch     1.7.18-1.fc20        updates      71 k
 wine-openal                  i686       1.7.18-1.fc20        updates      56 k
 wine-pulseaudio              i686       1.7.18-1.fc20        updates      81 k
 wine-small-fonts             noarch     1.7.18-1.fc20        updates      59 k
 wine-symbol-fonts            noarch     1.7.18-1.fc20        updates      70 k
 wine-system-fonts            noarch     1.7.18-1.fc20        updates      63 k
 wine-systemd                 noarch     1.7.18-1.fc20        updates      45 k
 wine-tahoma-fonts            noarch     1.7.18-1.fc20        updates     148 k
 wine-twain                   i686       1.7.18-1.fc20        updates      74 k
 wine-wingdings-fonts         noarch     1.7.18-1.fc20        updates      56 k
 wine-wow                     i686       1.7.18-1.fc20        updates     227 k
"""

dnf:
"""
================================================================================
 Package                      Arch       Version              Repository   Size
================================================================================
Installing:
 wine                         i686       1.7.18-1.fc20        updates      44 k
 mingw32-wine-gecko           noarch     2.24-1.fc20          fedora       21 M
 wine-openal                  i686       1.7.18-1.fc20        updates      56 k
 wine-desktop                 x86_64     1.7.18-1.fc20        updates     147 k
 wine-pulseaudio              i686       1.7.18-1.fc20        updates      81 k
 wine-wow                     i686       1.7.18-1.fc20        updates     227 k
 wine-fonts                   noarch     1.7.18-1.fc20        updates      44 k
 wine-cms                     i686       1.7.18-1.fc20        updates      65 k
 wine-mono                    noarch     4.5.2-1.fc20         updates      51 M
 wine-capi                    i686       1.7.18-1.fc20        updates      50 k
 wine-ldap                    i686       1.7.18-1.fc20        updates     115 k
 wine-twain                   i686       1.7.18-1.fc20        updates      74 k
 wine-core                    i686       1.7.18-1.fc20        updates      19 M
 wine-common                  noarch     1.7.18-1.fc20        updates      98 k
 wine-openal                  x86_64     1.7.18-1.fc20        updates      58 k
 wine-systemd                 noarch     1.7.18-1.fc20        updates      45 k
 wine-pulseaudio              x86_64     1.7.18-1.fc20        updates      82 k
 wine-wow                     x86_64     1.7.18-1.fc20        updates     229 k
 wine-system-fonts            noarch     1.7.18-1.fc20        updates      63 k
 wine-tahoma-fonts            noarch     1.7.18-1.fc20        updates     148 k
 wine-marlett-fonts           noarch     1.7.18-1.fc20        updates      56 k
 wine-ms-sans-serif-fonts     noarch     1.7.18-1.fc20        updates      71 k
 wine-fixedsys-fonts          noarch     1.7.18-1.fc20        updates      57 k
 wine-small-fonts             noarch     1.7.18-1.fc20        updates      59 k
 wine-wingdings-fonts         noarch     1.7.18-1.fc20        updates      56 k
 wine-courier-fonts           noarch     1.7.18-1.fc20        updates      58 k
 wine-symbol-fonts            noarch     1.7.18-1.fc20        updates      70 k
 wine-cms                     x86_64     1.7.18-1.fc20        updates      67 k
 wine-capi                    x86_64     1.7.18-1.fc20        updates      50 k
 wine-ldap                    x86_64     1.7.18-1.fc20        updates     119 k
 wine-twain                   x86_64     1.7.18-1.fc20        updates      76 k
 nss-mdns                     i686       0.10-13.fc20         fedora       29 k
 wine-filesystem              noarch     1.7.18-1.fc20        updates      72 k
 wine-core                    x86_64     1.7.18-1.fc20        updates      19 M
 libgphoto2                   i686       2.5.3-6.fc20         updates     1.2 M
 gd                           i686       2.1.0-3.fc20         fedora      136 k
 libXpm                       i686       3.5.10-5.fc20        fedora       52 k
 libusbx                      i686       1.0.18-1.fc20        updates      59 k
 libvpx                       i686       1.3.0-4.fc20         updates     512 k
 samba-winbind-clients        x86_64     2:4.1.6-1.fc20       updates     112 k
 iniparser                    x86_64     3.1-3.fc20           fedora       13 k
 samba-winbind                x86_64     2:4.1.6-1.fc20       updates     445 k
 wine-alsa                    x86_64     1.7.18-1.fc20        updates      93 k
 samba-winbind-modules        x86_64     2:4.1.6-1.fc20       updates      92 k
"""

Comment 3 Ales Kozumplik 2014-06-02 06:31:50 UTC
I think this is because how we treat filename installs---Jan, please take a look.

Comment 4 Honza Silhan 2014-07-21 14:01:49 UTC
Fixed in the upstream. The latter report of installing wine-core package of both architectures has not been solved as it's different and more compilicated depsolving issue. Simon, file a new bug, please.

Comment 5 Honza Silhan 2014-09-29 12:05:28 UTC
*** Bug 1147034 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.