Bug 1100964 - Cloning git repositories with hggit over ssh hangs
Summary: Cloning git repositories with hggit over ssh hangs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-dulwich
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fabian Affolter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-24 14:44 UTC by thomasbilk
Modified: 2014-06-12 03:49 UTC (History)
2 users (show)

Fixed In Version: python-dulwich-0.9.6-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-10 02:57:59 UTC


Attachments (Terms of Use)

Description thomasbilk 2014-05-24 14:44:26 UTC
Description of problem:
Dulwich is needed for the hggit plugin for mercurial. There is a bug in the Heisenbug Dulwich (0.9.1) that is fixed in Dulwich 0.9.6

Version-Release number of selected component (if applicable):
0.9.1

How reproducible:
Happens every time I try to clone a repository with ssh, works without problems with http(s).


Steps to Reproduce:
Clone any repository from Github with ssh like so: 
hg clone git+ssh://git@github.com:jelmer/dulwich.git 

Actual results:
Hangs

Expected results:
Clones

Additional info:
Fixed in Dulwich 0.9.6

Comment 1 Fedora Update System 2014-05-26 15:17:16 UTC
python-dulwich-0.9.6-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/python-dulwich-0.9.6-1.fc20

Comment 2 Fedora Update System 2014-05-26 17:44:21 UTC
python-dulwich-0.9.6-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-dulwich-0.9.6-1.fc19

Comment 3 Fedora Update System 2014-05-26 23:58:29 UTC
Package python-dulwich-0.9.6-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-dulwich-0.9.6-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6725/python-dulwich-0.9.6-1.fc20
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2014-06-10 02:57:59 UTC
python-dulwich-0.9.6-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2014-06-10 03:03:49 UTC
python-dulwich-0.9.6-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Dan Callaghan 2014-06-12 03:49:18 UTC
0.9.6 should not have been pushed to stable Fedora releases because it has quite a number of API changes from 0.9.1. The one that hit me was the removal of the Repo.revision_history method.

I don't think it's worth the whole downgrade epoch dance, so I guess there is nothing else to be done about it now. But please be more careful next time.


Note You need to log in before you can comment on or make changes to this bug.