Bug 110110 - scanimage stopped working
scanimage stopped working
Status: CLOSED DUPLICATE of bug 110174
Product: Red Hat Linux
Classification: Retired
Component: sane-backends (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-14 16:36 EST by keith adamson
Modified: 2007-04-18 12:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description keith adamson 2003-11-14 16:36:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
scanimage stopped working recently ... xsane still works though.

Had a command like:

scanimage --device-name=epson:/dev/usb/scanner0 --format=tiff \
          --verbose \
          --batch='page%03d.ti' --batch-start=1 \
          --resolution 600 --quick-format Letter --source Automatic

In a shell script that was working a few weeks ago.  Now I get an error:

scanimage: open of device epson:/dev/usb/scanner0 failed: Invalid
argument.  

When I run:

# scanimage --list-devices
 
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

When I run:

# sane-find-scanner
 
  # No SCSI scanners found. If you expected something different, make
sure that
  # you have loaded a SCSI driver for your SCSI adapter.
 
found USB scanner (vendor=0x04b8, product=0x010a) at /dev/usb/scanner0
found USB scanner (vendor=0x04b8 [EPSON], product=0x010a
[Perfection1640]) at libusb:001:003
  # A USB device was detected. This program can't be sure if it's really
  # a scanner. If it is your scanner, it may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.
 
  # Scanners connected to the parallel port or other proprietary ports
can't be
  # detected by this program.

When I run xsane it runs fine:

# xsane
[epson] Requesting extended status
[epson] No error
[epson] Checking for ADF: (80)
[epson] Checking for TPU: (00)
[epson] Device name = Perfection1640

# cat /proc/bus/usb/devices
T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=12  MxCh= 2
B:  Alloc=  0/900 us ( 0%), #Int=  0, #Iso=  0
D:  Ver= 1.00 Cls=09(hub  ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0000 ProdID=0000 Rev= 0.00
S:  Product=USB UHCI Root Hub
S:  SerialNumber=d400
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=09(hub  ) Sub=00 Prot=00 Driver=hub
E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=255ms
T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  3 Spd=12  MxCh= 0
D:  Ver= 1.10 Cls=ff(vend.) Sub=ff Prot=ff MxPS=64 #Cfgs=  1
P:  Vendor=04b8 ProdID=010a Rev= 1.03
S:  Manufacturer=EPSON
S:  Product=Perfection1640
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr=  2mA
I:  If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=usbscanner
E:  Ad=81(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms

# cat /proc/bus/usb/drivers
         usbdevfs
         hub
 96-111: hiddev
         hid
 48- 63: usbscanner

# cat /etc/sane.d/epson.conf
usb /dev/usb/scanner0





Version-Release number of selected component (if applicable):
sane-backends-1.0.9-5.1

How reproducible:
Always

Steps to Reproduce:
1.run scanimage
2.doesn't see scanner

repeated on two different computers
    

Actual Results:  error

Expected Results:  scan image

Additional info:
Comment 1 Tim Waugh 2003-11-14 17:40:28 EST
What changed in the time between it working and not working?
Comment 2 Michael 2003-11-16 12:04:42 EST
I've got an Epson 1240U with sane-backends-1.0.9-5.1 installed on a
RHL9 system.
My scanner stopped working (via scanimage; xsane still worked) when I
applied a batch of updates last night.
 
From a "what changed" perspective, glibc-2.3.2-27.9.6 &
glibc-2.3.2-27.9.7 are the guilty culprits.
 
Downgrading via an "rpm --oldpackage -Uvh
i686/glibc-2.3.2-27.9.i686.rpm [and i386/glibc-common + ncsc] (April
9, 2003 eratta) fixes the problem, but you miss out on the fixes in
the recent errata.
Comment 3 Tim Waugh 2003-11-17 07:33:57 EST
Please attach the output of 'strace scanimage ...' for the command
that fails.  Thanks.
Comment 4 keith adamson 2003-11-17 10:40:04 EST
Packages install since stopped working

nscd-2.3.2-27.9.7
glibc-devel-2.3.2-27.9.7
glibc-2.3.2-27.9.7
glibc-common-2.3.2-27.9.7
ethereal-0.9.16-0.90.1
ethereal-gnome-0.9.16-0.90.1

# strace scanimage --device-name=epson:/dev/usb/scanner0 --format=tiff \
>           --verbose \
>           --batch='page%03d.ti' --batch-start=1 \
>           --resolution 600 --quick-format Letter --source Automatic
execve("/usr/bin/scanimage", ["scanimage",
"--device-name=epson:/dev/usb/scanner0", "--format=tiff", "--verbose",
"--batch=page%03d.ti", "--batch-start=1", "--resolution", "600",
"--quick-format", "Letter", "--source", "Automatic"], [/* 23 vars */]) = 0
uname({sys="Linux", node="sandnt17562.na.ngrid.net", ...}) = 0
brk(0)                                  = 0x8051cc8
open("/etc/ld.so.preload", O_RDONLY)    = -1 ENOENT (No such file or
directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=68651, ...}) = 0
old_mmap(NULL, 68651, PROT_READ, MAP_PRIVATE, 3, 0) = 0x40016000
close(3)                                = 0
open("/usr/lib/sane/libsane.so.1", O_RDONLY) = 3
read(3,
"\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0P\26\0\000"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=26344, ...}) = 0
old_mmap(NULL, 25460, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x40027000
old_mmap(0x4002d000, 4096, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED, 3, 0x6000) = 0x4002d000
close(3)                                = 0
open("/lib/libdl.so.2", O_RDONLY)       = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\340\30"...,
512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=15900, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS,
-1, 0) = 0x4002e000
old_mmap(NULL, 13176, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x4002f000
old_mmap(0x40032000, 4096, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED, 3, 0x2000) = 0x40032000
close(3)                                = 0
open("/lib/libnsl.so.1", O_RDONLY)      = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0p<\0\000"...,
512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=91624, ...}) = 0
old_mmap(NULL, 85184, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x40033000
old_mmap(0x40045000, 4096, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED, 3, 0x11000) = 0x40045000
old_mmap(0x40046000, 7360, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x40046000
close(3)                                = 0
open("/usr/lib/libusb-0.1.so.4", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\370\20"...,
512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=25004, ...}) = 0
old_mmap(NULL, 27976, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) = 0x40048000
old_mmap(0x4004d000, 8192, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED, 3, 0x4000) = 0x4004d000
close(3)                                = 0
open("/lib/tls/libm.so.6", O_RDONLY)    = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\2004\0"...,
512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=212020, ...}) = 0
old_mmap(NULL, 138496, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) =
0x4004f000
old_mmap(0x40070000, 4096, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED, 3, 0x20000) = 0x40070000
close(3)                                = 0
open("/usr/lib/libjpeg.so.62", O_RDONLY) = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\260$\0"...,
512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=121028, ...}) = 0
old_mmap(NULL, 119908, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0) =
0x40071000
old_mmap(0x4008e000, 4096, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED, 3, 0x1d000) = 0x4008e000
close(3)                                = 0
open("/lib/tls/libc.so.6", O_RDONLY)    = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\360W\1"...,
512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=1539996, ...}) = 0
old_mmap(0x42000000, 1267276, PROT_READ|PROT_EXEC, MAP_PRIVATE, 3, 0)
= 0x42000000
old_mmap(0x42130000, 12288, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED, 3, 0x130000) = 0x42130000
old_mmap(0x42133000, 9804, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x42133000
close(3)                                = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS,
-1, 0) = 0x4008f000
set_thread_area({entry_number:-1 -> 6, base_addr:0x4008f760,
limit:1048575, seg_32bit:1, contents:0, read_exec_only:0,
limit_in_pages:1, seg_not_present:0, useable:1}) = 0
munmap(0x40016000, 68651)               = 0
brk(0)                                  = 0x8051cc8
brk(0x8052cc8)                          = 0x8052cc8
brk(0)                                  = 0x8052cc8
brk(0x8053000)                          = 0x8053000
open("./v4l.conf", O_RDONLY)            = -1 ENOENT (No such file or
directory)
open("/etc/sane.d/v4l.conf", O_RDONLY)  = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=204, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0x40016000
read(3, "#\n# In order to use the v4linux "..., 4096) = 204
open("/dev/bttv0", O_RDWR)              = -1 ENOENT (No such file or
directory)
open("/dev/video0", O_RDWR)             = -1 ENODEV (No such device)
open("/dev/video1", O_RDWR)             = -1 ENODEV (No such device)
open("/dev/video2", O_RDWR)             = -1 ENODEV (No such device)
open("/dev/video3", O_RDWR)             = -1 ENODEV (No such device)
read(3, "", 4096)                       = 0
close(3)                                = 0
munmap(0x40016000, 4096)                = 0
write(2, "scanimage: open of device epson:"..., 75scanimage: open of
device epson:/dev/usb/scanner0 failed: Invalid argument
) = 75
exit_group(1)                           = ?
Comment 5 keith adamson 2003-11-17 10:52:44 EST
BTW fedora works ... tested on different system
Comment 6 Tim Waugh 2003-11-19 07:04:54 EST
Really strange.

Please try this:

SANE_DEBUG_DLL=4
export SANE_DEBUG_DLL
scanimage ... (as normal)

What does it say?
Comment 7 Ed Hagerty 2003-12-20 19:34:58 EST
I have the same problem as Keith, xsane works fine but scanimage does 
not.  I get the same output from strace as he does.

When I set SANE_DEBUG_DLL as requested I get no new information - 
only the old error message of "scanimage: open of device epson:
/dev/usb/scanner0 failed: Invalid argument"

Any ideas?
Comment 8 Tim Waugh 2003-12-23 10:31:53 EST

*** This bug has been marked as a duplicate of 110174 ***
Comment 9 Red Hat Bugzilla 2006-02-21 14:00:00 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.