Bug 110111 - Mobility FireGL 7800 M7 doesn't clone well, weird drawing on external display
Mobility FireGL 7800 M7 doesn't clone well, weird drawing on external display
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-14 16:37 EST by Keith T. Garner
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 02:30:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith T. Garner 2003-11-14 16:37:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031110 Firebird/0.7

Description of problem:
On my Thinkpad A31p with a Radeon Mobility FireGL 7800 M7 a lot of
issues having to do with a cloned display stopped working when I
upgraded from RH9 to Fedora Core 1.

1) If I boot into X with the laptop lid closed, the internal display
cannot be turned back on.  I have tried opening the lid and doing the
Fn-F7 combination, and it just does not switch.

2) Drawing on the external display, especially with things that move
rapidly (block curser, mouse pointer,) has issues.  The best way I can
explain this is it looks like verticle interlacing while the object is
moving.  Its very distracting, especially with the block curser in my
konsoles.  This interlacing effect can also be seen when running
glxgears.  (So much for gaming.  :) )

3) The xvideo overlay, when in cloned mode, is only appearing on the
internal or the external display, but never both.  (Its toggled by
setting the OverlayOnCRTC2 option.  In RH9, it would appear on both.

These problems are quite annoying as I used to suspend and unsuspend
my laptop for a week at a time, but with X only attaching itself to
one display if I boot the wrong way, I cannot do that.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-42

How reproducible:
Always

Steps to Reproduce:
For number 1 above:
1. Run X by booting/starting X with lid closed

The other two happen no matter how I boot, I just need to be running
X.    

Additional info:

I'm more than willing to be a test dummy and help out anyway I can in
collecting this information.
Comment 1 Mike A. Harris 2003-11-14 17:08:54 EST
All bug reports need to be filed as one bug being reported per bug
report, so that individual issues can be tracked, and once they're
resolved, they can be closed one at a time without having to wait
for the whole group to be closed out.

For issue #1:  Can't help you with that problem as I don't have any
ATI Radeon Mobility hardware at all.  You'll have to report that issue
to XFree86.org bugzilla at http://bugs.xfree86.org for someone who
has the hardware to investigate.  Using special hotkeys on a laptop
does not invoke X server features or functionality, it invokes BIOS
features, and may conflict with the video driver.  I can't really
do anything about this either way however, as I don't have the
hardware at all.

Issue #2: I can't picture this to know what could be the cause.  Make
sure acceleration is not disabled, and that you're using the Red Hat
kernel and MTRR is working properly.  I can try to reproduce this
on desktop hardware sometime, but you'll need to file a separate
bug report for me to track that one issue.  You should also file
that report to XFree86.org so that it isn't a problem in 4.4.0 if it
is indeed an XFree86 bug.

Issue #3: Radeon hardware supports only a single video overlay, and
that overlay can only be on one CRT or the other at a time, so it is
not possible to have an Xvideo overlay on both windows simultaneously.
XFree86 4.5.0 (or whatever is after 4.4.0) will have a new special
mode for the Radeon called MergedFB mode which allows both screens
to share the same framebuffer.  When MergedFB is available, the
video overlay works across screens, but that wont be for a long time.

All of these 3 problems really require physical access to the
specific hardware in order for a developer to be able to investigate
them.  I do not have Radeon Mobility hardware, and so I wont likely
be able to do anything about these problems other than review patches
that others provide, or backport known fixes from XFree86 CVS that
people claim fixes the problem for them.  My recommendation is to
test the current XFree86 CVS head Radeon support, and if the
problems persist, to file these 3 issues as separate bug reports
in XFree86 bugzilla, so they can be tracked by the entire range
of developers working on the XFree86 radeon driver, of whom one
or more might perhaps have Radeon Mobility access.

You might also want to post about these problems on the XFree86
mailing list xfree86@xfree86.org and see what turns up.

If you file bug reports upstream, please include the bug URL(s) here
so I can track the issues upstream and investigate potential inclusion
of any fixes that show up.

Thanks in advance.
Comment 2 Mike A. Harris 2003-11-14 17:14:39 EST
Hmm, I just reread #2...  Are you saying your mouse cursor is
being corrupted?  If so, try using:

    Option "swcursor"

in the device section of the config file.
Comment 3 Keith T. Garner 2003-11-14 17:17:58 EST
This happens with the 'text' cursor in a konsole as well.  Unless that
is done at the hardware level as well....  I'll give swcursor a try.

Also, I'll be good and file seperate reports for the other issues.
Comment 4 Mike A. Harris 2003-11-14 17:55:58 EST
Can you take screenshots of the corruption?  That might help quite a
bit perhaps.  If the problem doesn't show up in a screenshot, can you
take some high-res digital pictures with no flash?  Preferably .png as
they have no lossy compression... unless the camera's native format is
.jpg  (mine is, bleah)

Sometimes a picture is worth a thousand words.  ;o)
Comment 5 Keith T. Garner 2003-11-24 10:17:29 EST
I haven't had a chance to get those screenshots yet.  However, on a
whim, I booted into X without the external monitor attached.  After X
was up, I attached the external monitor, and behaviour above worked as
expected (for all three items, yes, I need seperate bugs files for two
of them.)
Comment 6 Mike A. Harris 2004-10-12 02:30:35 EDT
Since this bugzilla report was filed, there have been several major
updates to the X Window System, which may resolve this issue.  Users
who have experienced this problem are encouraged to upgrade to the
latest version of Fedora Core, which can be obtained from:

If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Note You need to log in before you can comment on or make changes to this bug.