Bug 1101111 - [RFE] Add regression tests for the component geo-replication
Summary: [RFE] Add regression tests for the component geo-replication
Keywords:
Status: CLOSED DUPLICATE of bug 1227624
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-26 07:38 UTC by Vijaykumar Koppad
Modified: 2017-03-08 09:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-08 09:17:39 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Vijaykumar Koppad 2014-05-26 07:38:47 UTC
Description of problem: Add regression tests for the component geo-replication 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2014-05-26 07:39:26 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep) posted (#8) for review on master by Vijaykumar Koppad (vkoppad@redhat.com)

Comment 2 Anand Avati 2014-06-13 12:31:50 UTC
REVIEW: http://review.gluster.org/8063 (Geo-rep: Adding regression tests for geo-rep) posted (#1) for review on master by Vijaykumar Koppad (vkoppad@redhat.com)

Comment 3 Anand Avati 2014-06-13 12:39:23 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep) posted (#9) for review on master by Vijaykumar Koppad (vkoppad@redhat.com)

Comment 4 Anand Avati 2014-06-25 12:40:42 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep) posted (#10) for review on master by ajeet jha (ajha@redhat.com)

Comment 5 Anand Avati 2014-07-02 06:05:36 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep) posted (#11) for review on master by ajeet jha (ajha@redhat.com)

Comment 6 Anand Avati 2014-07-02 09:58:54 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep) posted (#12) for review on master by ajeet jha (ajha@redhat.com)

Comment 7 Anand Avati 2014-07-04 07:26:39 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep) posted (#13) for review on master by Vijaykumar Koppad (vkoppad@redhat.com)

Comment 8 Anand Avati 2014-07-04 12:13:59 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep) posted (#14) for review on master by Vijaykumar Koppad (vkoppad@redhat.com)

Comment 9 Anand Avati 2014-07-09 07:56:35 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep) posted (#15) for review on master by ajeet jha (ajha@redhat.com)

Comment 10 Anand Avati 2014-08-01 11:13:03 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep) posted (#16) for review on master by ajeet jha (ajha@redhat.com)

Comment 11 Anand Avati 2014-08-04 06:32:14 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep) posted (#17) for review on master by ajeet jha (ajha@redhat.com)

Comment 12 Anand Avati 2014-08-04 12:43:34 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep) posted (#18) for review on master by ajeet jha (ajha@redhat.com)

Comment 13 Anand Avati 2014-08-04 12:43:38 UTC
REVIEW: http://review.gluster.org/8411 (Automated configuration for geo-rep regression) posted (#1) for review on master by ajeet jha (ajha@redhat.com)

Comment 14 Anand Avati 2014-08-04 12:47:23 UTC
REVIEW: http://review.gluster.org/8411 (tests/geo-rep: Automated configuration for geo-rep regression.) posted (#2) for review on master by ajeet jha (ajha@redhat.com)

Comment 16 Anand Avati 2014-09-08 12:16:25 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep.) posted (#19) for review on master by ajeet jha (ajha@redhat.com)

Comment 17 Anand Avati 2014-09-09 11:04:38 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep.) posted (#20) for review on master by ajeet jha (ajha@redhat.com)

Comment 18 Anand Avati 2014-09-13 18:39:29 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep.) posted (#21) for review on master by ajeet jha (ajha@redhat.com)

Comment 19 Anand Avati 2014-09-19 11:39:26 UTC
REVIEW: http://review.gluster.org/8411 (tests/geo-rep: Automated configuration for geo-rep regression.) posted (#3) for review on master by ajeet jha (ajha@redhat.com)

Comment 20 Anand Avati 2014-09-19 11:39:30 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep.) posted (#22) for review on master by ajeet jha (ajha@redhat.com)

Comment 21 Anand Avati 2014-09-25 12:02:31 UTC
REVIEW: http://review.gluster.org/8411 (tests/geo-rep: Automated configuration for geo-rep regression.) posted (#4) for review on master by ajeet jha (ajha@redhat.com)

Comment 22 Anand Avati 2014-09-25 12:02:34 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep.) posted (#23) for review on master by ajeet jha (ajha@redhat.com)

Comment 23 Niels de Vos 2014-11-27 14:45:20 UTC
Feature requests make most sense against the 'mainline' release, there is no ETA for an implementation and requests might get forgotten when filed against a particular version.

Comment 24 Anand Avati 2014-12-17 08:37:12 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep.) posted (#24) for review on master by ajeet jha (ajha@redhat.com)

Comment 25 Anand Avati 2015-01-12 05:51:37 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep.) posted (#25) for review on master by ajeet jha (ajha@redhat.com)

Comment 26 Anand Avati 2015-02-12 12:14:26 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep.) posted (#26) for review on master by ajeet jha (ajha@redhat.com)

Comment 27 Anand Avati 2015-02-13 09:51:50 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep.) posted (#27) for review on master by ajeet jha (ajha@redhat.com)

Comment 28 Anand Avati 2015-02-13 10:08:12 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep.) posted (#28) for review on master by ajeet jha (ajha@redhat.com)

Comment 29 Anand Avati 2015-04-03 12:19:47 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep) posted (#29) for review on master by Kotresh HR (khiremat@redhat.com)

Comment 30 Anand Avati 2015-04-04 14:14:35 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep) posted (#30) for review on master by Kotresh HR (khiremat@redhat.com)

Comment 31 Anand Avati 2015-04-05 02:27:05 UTC
REVIEW: http://review.gluster.org/7392 (Geo-rep: Adding regression tests for geo-rep) posted (#31) for review on master by Kotresh HR (khiremat@redhat.com)

Comment 32 Anand Avati 2015-04-13 10:03:45 UTC
COMMIT: http://review.gluster.org/7392 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit b5d7faa96b5ca44be6899c6976691e0fde7d70d1
Author: Vijaykumar Koppad <vkoppad@redhat.com>
Date:   Fri Jun 13 17:52:30 2014 +0530

    Geo-rep: Adding regression tests for geo-rep
    
    This patch introduces upstream regression suit for geo-replication
    
        * Modifies cleanup (tests/include.rc) to remove everything but
          hook-scripts.
    
    Prerequisites:
        * Passwordless SSH from root to root of current host.
        * Export /build/install/sbin and /build/install/bin to PATH
          variable for root user.
    
    Change-Id: I433dd8bbb17edba9baaf516fe0dce3133ba39184
    BUG: 1101111
    Signed-off-by: Vijaykumar Koppad <vkoppad@redhat.com>
    Signed-off-by: Ajeet Jha <ajha@redhat.com>
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/7392
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 33 Anand Avati 2015-04-22 16:34:23 UTC
REVIEW: http://review.gluster.org/10340 (geo-rep: Regression tests improvements) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)

Comment 34 Anand Avati 2015-04-23 13:33:19 UTC
REVIEW: http://review.gluster.org/10340 (geo-rep: Regression tests improvements) posted (#2) for review on master by Kotresh HR (khiremat@redhat.com)

Comment 35 Aravinda VK 2015-05-10 03:44:51 UTC
Some more work expected to cleanup the Geo-rep Regression tests, moving this back to Assigned.

Comment 36 Kotresh HR 2016-03-11 09:04:09 UTC
There are following patches for this bug:
http://review.gluster.org/#/c/7392/ -> Main patch, merged.
http://review.gluster.org/#/c/10340/ -> Merged

http://review.gluster.org/#/c/8411/ -> Not needed. Should be abandoned
http://review.gluster.org/#/c/8063/ -> patch 7392 takes care of it. Hence Abandoned.

Moreover the above test suite for geo-replication is replaced with simple test suite. Please see following bug.

https://bugzilla.redhat.com/show_bug.cgi?id=1227624

Comment 37 Kotresh HR 2017-03-08 09:17:39 UTC

*** This bug has been marked as a duplicate of bug 1227624 ***


Note You need to log in before you can comment on or make changes to this bug.