Bug 110112 - OpenOffice startup spash logo blocks the screen
OpenOffice startup spash logo blocks the screen
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: openoffice.org (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-14 16:51 EST by Yue Shi Lai
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-21 16:17:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yue Shi Lai 2003-11-14 16:51:08 EST
Description of problem:

OpenOffice and its components have an unmanaged spash logo, which
essentially "hijacks" the middle part of the screen until the
application launches. 

Version-Release number of selected component (if applicable):

1.0.2-8 (essentially: all)

How reproducible:

Always

Steps to Reproduce:
1. Run some application in the middle of the screen.
2. Start an OpenOffice component.
3. Try to use the application in step 1.
  
Actual results:

The middle of the screen is blocked by the splash window, which is
unmanaged and cannot be moved, usage of the system is severely limited
until OpenOffice actually launches.

Expected results:

Either the splash should be managed and able to move into a
non-disturbing area of the screen, or do not use any splash.

Additional info:

This problem is especially annoying because the way to disable the
splash is undocumented (not even in the FAQ). Further information is
available from:

http://www.newsforge.com/software/03/04/22/1931223.shtml?tid=51

One solution would be to change "Logo=1" into "Logo=0" in

/usr/lib/openoffice/program/sofficerc
Comment 1 Suzanne Hillman 2003-11-17 14:52:23 EST
RFE logged as internal bug #110275 - will consider for future releases.
Comment 2 Dan Williams 2004-05-21 16:17:05 EDT
This is fixed on all versions of OpenOffice.org 1.1.x currently
shipped by Red Hat for:

Fedora Core 1
Fedora Core 2
RHEL3 U2

Note You need to log in before you can comment on or make changes to this bug.