Bug 1101152 - Add to the data reaper created task tags or task type
Summary: Add to the data reaper created task tags or task type
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Pulp
Classification: Retired
Component: async/tasks
Version: unspecified
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 2.6.0
Assignee: Dennis Kliban
QA Contact: Irina Gulina
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-26 10:04 UTC by Ina Panova
Modified: 2015-02-28 22:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-28 22:08:50 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Pulp Redmine 436 0 None None None Never

Description Ina Panova 2014-05-26 10:04:24 UTC
Description of problem:

There are tasks created for the data reaping, but they have no tags or task type. So when you are listing the tasks you cannot tell what this task was about, its purpose and where it comes from.


[root@ec2-54-246-60-188 ~]# pulp-admin -u admin -p admin tasks list
+----------------------------------------------------------------------+
                                 Tasks
+----------------------------------------------------------------------+

Operations:  
Resources:   
State:       Successful
Start Time:  2014-05-24T22:35:23Z
Finish Time: 2014-05-24T22:35:23Z
Task Id:     cb5e3318-b3d9-4568-812d-f92113dd0857


Operations:  
Resources:   
State:       Successful
Start Time:  2014-05-25T22:35:23Z
Finish Time: 2014-05-25T22:35:24Z
Task Id:     a4558b39-d412-4583-afb3-78ee1e119956

Operations:  sync
Resources:   xxx (repository)
State:       Successful
Start Time:  2014-05-26T09:51:18Z
Finish Time: 2014-05-26T09:51:19Z
Task Id:     7bf6807c-0ad2-4d92-b22c-833a35634a67

Operations:  delete
Resources:   xxx (repository)
State:       Successful
Start Time:  2014-05-26T09:53:24Z
Finish Time: 2014-05-26T09:53:25Z
Task Id:     93ed4b84-6c5f-458e-a782-125b64a20141


[root@ec2-54-246-60-188 ~]# pulp-admin -u admin -p admin tasks details --task-id 93ed4b84-6c5f-458e-a782-125b64a20141
+----------------------------------------------------------------------+
                              Task Details
+----------------------------------------------------------------------+

Operations:       delete
Resources:        xxx (repository)
State:            Successful
Start Time:       2014-05-26T09:53:24Z
Finish Time:      2014-05-26T09:53:25Z
Result:           N/A
Task Id:          93ed4b84-6c5f-458e-a782-125b64a20141
Progress Report:  


[root@ec2-54-246-60-188 ~]# pulp-admin -u admin -p admin tasks details --task-id a4558b39-d412-4583-afb3-78ee1e119956
+----------------------------------------------------------------------+
                              Task Details
+----------------------------------------------------------------------+

Operations:       
Resources:        
State:            Successful
Start Time:       2014-05-25T22:35:23Z
Finish Time:      2014-05-25T22:35:24Z
Result:           N/A
Task Id:          a4558b39-d412-4583-afb3-78ee1e119956
Progress Report:  None



Version-Release number of selected component (if applicable):
2.4.0-0.17.beta

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Dennis Kliban 2014-10-14 15:45:27 UTC
this is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1120671

This should be fixed on 2.5-dev and master.

Comment 2 Chris Duryee 2014-12-23 20:52:44 UTC
fixed in pulp 2.6.0-0.2.beta

Comment 3 Irina Gulina 2014-12-24 12:57:16 UTC
>> rpm -qa | grep pulp-server
pulp-server-2.6.0-0.2.beta.fc20.noarch


>> pulp-admin -u admin -p admin tasks list
+----------------------------------------------------------------------+
                                 Tasks
+----------------------------------------------------------------------+
.....

Operations:  reaper
Resources:   
State:       Successful
Start Time:  2014-12-23T20:56:27Z
Finish Time: 2014-12-23T20:56:27Z
Task Id:     51ef6383-dc0d-4428-8463-7ea935f66ea3

Operations:  delete
Resources:   test (repository)
State:       Successful
Start Time:  2014-12-23T23:43:27Z
Finish Time: 2014-12-23T23:43:27Z
Task Id:     4bfc4a02-3405-4661-843a-294208cb90f3

Operations:  reaper
Resources:   
State:       Successful
Start Time:  2014-12-24T04:53:04Z
Finish Time: 2014-12-24T04:53:04Z
Task Id:     a4eb34bf-a38d-483c-9175-743ab64ff0d3

Operations:  reaper
Resources:   
State:       Successful
Start Time:  2014-12-24T10:53:03Z
Finish Time: 2014-12-24T10:53:04Z
Task Id:     2ecf028d-80db-4fe6-a60b-9d18af4604a4

>> pulp-admin -u admin -p admin tasks details --task-id 2ecf028d-80db-4fe6-a60b-9d18af4604a4

+----------------------------------------------------------------------+
                              Task Details
+----------------------------------------------------------------------+

Operations:       reaper
Resources:        
State:            Successful
Start Time:       2014-12-24T10:53:03Z
Finish Time:      2014-12-24T10:53:04Z
Result:           N/A
Task Id:          2ecf028d-80db-4fe6-a60b-9d18af4604a4
Progress Report:

Comment 4 Brian Bouterse 2015-02-28 22:08:50 UTC
Moved to https://pulp.plan.io/issues/436


Note You need to log in before you can comment on or make changes to this bug.