Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1101251 - Upgrade perl-DateTime-TimeZone to deliver time zone updates
Upgrade perl-DateTime-TimeZone to deliver time zone updates
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: perl-DateTime-TimeZone (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Petr Pisar
Martin Kyral
Adam Kvitek
http://search.cpan.org/dist/DateTime-...
: Patch, Rebase
Depends On: 1136407
Blocks: 1191019 1420851 1465904 1466370 1110708
  Show dependency treegraph
 
Reported: 2014-05-26 08:58 EDT by Petr Pisar
Modified: 2018-04-10 04:38 EDT (History)
7 users (show)

See Also:
Fixed In Version: perl-DateTime-TimeZone-1.70-1.el7
Doc Type: Rebase: Bug Fixes Only
Doc Text:
The *DateTime::TimeZone* Perl module is now aware of recent time zone updates Previously, the Olson time zone database was outdated. As a consequence, applications written in the Perl language that use the *DateTime::TimeZone* module mishandled time zones that changed their specifications since version 2013h. The _perl-DateTime-TimeZone_ package has been rebased to version 1.70, and the Olson time zone database has been updated to version 2017b. As a result, the *DateTime::TimeZone* module is aware of all time zone updates until version 2017b.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 04:38:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Source repository patch on top of bug #1241818 (20.73 KB, patch)
2017-07-11 05:01 EDT, Petr Pisar
no flags Details | Diff
Source repository patch on top of bug #1241818 (23.03 KB, patch)
2017-07-11 08:24 EDT, Petr Pisar
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0664 None None None 2018-04-10 04:38 EDT

  None (edit)
Description Petr Pisar 2014-05-26 08:58:52 EDT
Current distributions provides version 1.63. There are new upstream releases, latest is 1.69 now:

The release updates Perl time zone database to IANA verions 2014c. It inlcudes
changes for Crimea and Troll Station in Antarctica, Egypt, and Turkey. The
release fixes running under taint mode id "local" time zone is used.

To provide current time zone data for Perl applications and libraries, it's necessary to rebase perl-DateTime-TimeZone to the latest version.
Comment 1 Petr Pisar 2014-09-02 08:40:52 EDT
Current upstream version is 1.74. The changes since 1.69 are:

1.74    2014-08-30

- This release is based on version 2014g of the Olson database. This release
  includes contemporary changes for Turks & Caicos.

- Fixed a bug when trying to get the local timezone by looking at
  /etc/sysconfig/clock. Patch by Alexey Molchanov. GitHub PR #2.


1.73    2014-08-06

- This release is based on version 2014f of the Olson database. This release
  includes contemporary changes for Russia and Australia.


1.72    2014-08-03

- Added support for getting the local time zone on Android. Patch from Brian
  Fraser. RT #97711.

- The primary repo for this distro is now on GitHub.


1.71    2014-06-21

- This release is based on version 2014e of the Olson database. This release
  includes contemporary changes for Egypt and Morocco.


1.70    2014-06-01

- Unset $ENV{TZ} in the t/04local.t test to avoid interference from
  the system. Reported by Mark Gardner. RT #96083.

- This release is based on version 2014d of the IANA database, but there are
  no data changes from 2014c.


The 1.74 breaks perl-DateTime tests. There is a simple fix for the perl-DateTime <http://pkgs.fedoraproject.org/cgit/perl-DateTime.git/commit/?h=f20&id=7a22f1f6770a1b0efa703fbbec433bb9a61e7566>.
Comment 2 Petr Pisar 2014-09-02 09:53:07 EDT
The 1.71 version requires a new Perl module List::AllUtils.
Comment 3 Petr Pisar 2014-09-02 09:59:50 EDT
(In reply to Petr Pisar from comment #2)
> The 1.71 version requires a new Perl module List::AllUtils.

Which would require rebasing perl-Scalar-List-Utils and a new perl-Test-Warnings package.

It's getting complicated.

We will see if we can update time zone data only without touch the library and tests.
Comment 4 Petr Pisar 2014-09-05 08:08:27 EDT
Due to dependencies there will be no rebase of this package. We will try to update the time zone database only without touching the code.
Comment 10 Petr Pisar 2017-07-11 05:01 EDT
Created attachment 1296137 [details]
Source repository patch on top of bug #1241818

This dist-git patch on top of 1.64 rebase (bug #1241818) rebases to 1.70 and then adds 2017b tzdata sources and regenerates the Perl code from them.
Comment 11 Petr Pisar 2017-07-11 08:24 EDT
Created attachment 1296212 [details]
Source repository patch on top of bug #1241818

This adds a correction for parsing short time zones with signs that exists in Africa/Accra since 2017a time zone data.
Comment 12 Petr Pisar 2017-08-17 06:57:08 EDT
How to test:

(1) Use DateTime Perl object with time and time zone whose rules changed after releasing 2013h Olson database (bundled within the old perl-DateTime-TimeZone-1.63-2.el7 package) and before relasing 2017b Olson database (provided within the new perl-DateTime-TimeZone-1.70-1.el7 package). E.g. this command:

  $ perl -e 'use DateTime; my $d=DateTime->new(year=>2015,month=>5,day=>1,hour=>0,minute=>0,second=>0,time_zone=>q{UTC}); $d->set_time_zone(q{Asia/Ulaanbaatar}); print $d->strftime(q{%FT%T%z}), qq{\n}'

Before:
  2015-05-01T08:00:00+0800
After:
  2015-05-01T09:00:00+0900

(2) You can compare it with date(1) output that uses database from tzdata package:

  $ TZ=Asia/Ulaanbaatar date --date '2015-05-01T00:00:00+0000' '+%FT%T%z'
  2015-05-01T09:00:00+0900
Comment 20 errata-xmlrpc 2018-04-10 04:38:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0664

Note You need to log in before you can comment on or make changes to this bug.