This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 110130 - Samba 3 group share
Samba 3 group share
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: samba (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-14 19:13 EST by Gaurav Walia
Modified: 2014-08-31 19:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-02 18:40:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gaurav Walia 2003-11-14 19:13:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/85.7 (KHTML, like Gecko) Safari/85.5

Description of problem:
It does not work.  let me clarify what I would like to do. 
 
target Directory :  software 
directory owner: root 
groups : softw - users can write, read to the folder 
              softr  - users can only read and execute. 
 
1. users cannot access the directory unless in either "softw" and "softr" group.
2. users in the "softr" group, users can access only read and execute the 
content of the directory 
through the samba interface.   
3. users in the "softw" group, users can write and modify the directory through 
the samba 
interface. 

worked previously in AS 2.1. Worked through AS support and they suggested this issue was a bug.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. create group softw, and softr
2. edit smb.conf and add
[software]
   comment = Software
   path = /home/share/software
   public = no
   writable = no
   printable = no
   write list = @softw
   read list = @softr

3. windows side access server \\server\share

    

Actual Results:  users can read directory 

Expected Results:  users cannot access the folder unless in either "softw" and "softr" group.

Additional info:
Comment 1 Jay Fenlason 2004-12-02 18:40:26 EST
I added "valid users = @softw, @softr" and it works as expected.  user smbdvl1 
is a member of softw, and can read and write the share.  User smbdvl2 is a 
member of softr and can only read the share.  User smbdvl3 is not a member of 
either group and cannot access the share. 

Note You need to log in before you can comment on or make changes to this bug.