Bug 1101325 - error: unpacking of archive failed on file /var/lock/uucp: cpio: mkdir
Summary: error: unpacking of archive failed on file /var/lock/uucp: cpio: mkdir
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: uucp
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Raiskup
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 998737
TreeView+ depends on / blocked
 
Reported: 2014-05-26 22:49 UTC by Lee Howard
Modified: 2014-06-12 06:28 UTC (History)
3 users (show)

Fixed In Version: uucp-1.07-42.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-12 06:23:20 UTC


Attachments (Terms of Use)

Description Lee Howard 2014-05-26 22:49:39 UTC
Description of problem (from koji build root.log):

DEBUG util.py:282:  Error unpacking rpm package uucp-1.07-38.fc19.x86_64
DEBUG util.py:282:  error: unpacking of archive failed on file /var/lock/uucp: cpio: mkdir
DEBUG util.py:282:  error: uucp-1.07-38.fc19.x86_64: install failed


How reproducible:

Use koji to build a package with a uucp dependency.


The resolution to Bug 998737 introduces a dependency of uucp in hylafax+.  However, koji builds for f19 and f20 fail (whereas f21, el5, and el6 apparently succeed) due to some kind of problem with unpacking/creating /var/lock/uucp when package uucp is installed onto the vm.

This is blocking hylafax+ updates on f19 and f20 and the resolution of Bug 998737.

Comment 1 Fedora Update System 2014-05-27 14:51:27 UTC
uucp-1.07-42.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/uucp-1.07-42.fc20

Comment 2 Fedora Update System 2014-05-27 14:52:03 UTC
uucp-1.07-42.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/uucp-1.07-42.fc19

Comment 3 Fedora Update System 2014-05-28 02:52:11 UTC
Package uucp-1.07-42.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing uucp-1.07-42.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6751/uucp-1.07-42.fc19
then log in and leave karma (feedback).

Comment 4 Lee Howard 2014-05-28 04:10:31 UTC
Thank you.  I don't know how apply the uucp update to koji builds other than simply waiting for it to mature and release.  (?)

Comment 5 Pavel Raiskup 2014-05-28 10:02:44 UTC
(In reply to Lee Howard from comment #4)
> Thank you.  I don't know how apply the uucp update to koji builds other than
> simply waiting for it to mature and release.  (?)

Lee, I submitted buildroot override [1] right now:

  Your buildroot override has been successfully tagged. It may take up to 20
  minutes for the buildroot to regenerate.

[1] http://fedoraproject.org/wiki/Bodhi/BuildRootOverrides

Comment 6 Nils Philippsen 2014-05-28 11:22:12 UTC
Hmm, I'm still at a loss why the error in comment #0 happens in F19, F20 but not F21:

The filesystem package tries to create the /var/lock symlink in %pretrans, but this should fail on all three because the /var directory doesn't exist at that point (unless koji/mock creates it in Rawhide but not the old releases).

Ondrej?

Comment 7 Pavel Raiskup 2014-05-28 11:37:37 UTC
Seems like on Rawhide is installed "lockdev" before uucp?

Comment 8 Ondrej Vasik 2014-05-28 12:04:28 UTC
Maybe - I should probably add posix.mkdir(/var) into filesystem to prevent it anyway...

Comment 9 Fedora Update System 2014-06-12 06:23:20 UTC
uucp-1.07-42.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2014-06-12 06:28:48 UTC
uucp-1.07-42.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.