Bug 1101352 - [UEFI] grub2-install grub2-install: error: modinfo.sh doesn't exist
Summary: [UEFI] grub2-install grub2-install: error: modinfo.sh doesn't exist
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-27 03:43 UTC by Chris Murphy
Modified: 2015-05-09 20:50 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-30 20:47:43 UTC


Attachments (Terms of Use)

Description Chris Murphy 2014-05-27 03:43:53 UTC
Description of problem: grub2-install command on UEFI appears to be broken. Fails.


Version-Release number of selected component (if applicable):
grub2-efi-2.02-0.3.fc21.x86_64
grub2-tools-2.02-0.3.fc21.x86_64

How reproducible:
Always


Steps to Reproduce:
1. New Live installation, or reinstalling grub2-efi grub2-tools packages.
2. grub2-install


Actual results:

grub2-install: error: /usr/lib/grub/x86_64-efi/modinfo.sh doesn't exist. Please specify --target or --directory.

Expected results:

grub2-install needs to work


Additional info:

  -d, --directory=DIR        use images and modules under DIR
                             [default=/usr/lib/grub/<platform>]

/usr/lib/grub is empty

Comment 1 Chris Murphy 2014-06-30 20:47:43 UTC
Looks like this is intentional to avoid the fallout of unsuspecting users running grub2-install. To regain ability to grub2-install on EFI, install package grub2-efi-modules. Closing.

Comment 2 Mustafa Muhammad 2015-05-09 15:53:32 UTC
(In reply to Chris Murphy from comment #1)
> Looks like this is intentional to avoid the fallout of unsuspecting users
> running grub2-install. To regain ability to grub2-install on EFI, install
> package grub2-efi-modules. Closing.

Is this documented somewhere, I think it should be written in errata.

Comment 3 Chris Murphy 2015-05-09 18:24:55 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1220066

Comment 4 Mustafa Muhammad 2015-05-09 20:50:56 UTC
(In reply to Chris Murphy from comment #3)
> https://bugzilla.redhat.com/show_bug.cgi?id=1220066

Thank you


Note You need to log in before you can comment on or make changes to this bug.