Bug 110153 - packages missing in rpmdb
packages missing in rpmdb
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpmdb-redhat (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-15 08:23 EST by David Juran
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-20 16:22:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Juran 2003-11-15 08:23:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
There are a some packages missing from the rpmdb which are in the FC1
distribution.
So far I've found comps and kernel...
Also, shouldn't this bugzilla component switch name to rpmdb-fedora?

Version-Release number of selected component (if applicable):
rpmdb-fedora-1-0.20031103

How reproducible:
Always

Steps to Reproduce:
1. rpm -q --dbpath /usr/lib/rpmdb/i386-redhat-linux/redhat/ kernel


Actual Results:  package kernel is not installed
Comment 1 Armijn Hemel 2004-01-31 17:23:02 EST
For some packages (such as XFree86) this is a problem. According to
rpmdb-fedora there is no package that provides kernel-drm, which
XFree86 needs. (This bug also applies to rpmdb-redhat in Red Hat 9 by
the way.)

And it makes my custom tools that work with the RPM database barf :(
Comment 2 Jos Vos 2004-04-05 16:47:27 EDT
About the missing comps package in rpmdb:
The comps package is not included because it is built after the whole
rpm tree (including rpmdb-*) is ready: the comps rpm includes the
final hdlist etc. and therefore has to be built as the very last
package, even after the distro is split into CD's. So, rpmdb will
never see the comps package.
Comment 3 Leonard den Ottolander 2004-04-25 18:32:25 EDT
Is there any reason not to include a (generic) kernel entry in the
rpmdb? Architecture of the package seems not to be an issue as glibc
is included. Is there an issue with systems having an smp kernel?
Maybe a %postinstall adding of a kernel[-smp] to the rpmdb? Or
%postinstall replacing an existing kernel entry with a kernel-smp
entry on smp systems?
Comment 4 Elliot Lee 2004-08-20 16:22:24 EDT
I think this should be fixed for Fedora in the future (but, you will
get multiple rpm db entries for things like the kernel - oh well! :)

Thanks for the bug report.

Note You need to log in before you can comment on or make changes to this bug.