Bug 1101557 - liveinst - rsync error: protocol incompatibility
Summary: liveinst - rsync error: protocol incompatibility
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rsync
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Luscon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ccc28137f63ee51881817c5982c...
: 1102977 (view as bug list)
Depends On:
Blocks: F21AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2014-05-27 13:59 UTC by satellitgo
Modified: 2014-06-01 00:01 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-30 09:09:16 UTC


Attachments (Terms of Use)
File: anaconda-tb (725.37 KB, text/plain)
2014-05-27 13:59 UTC, satellitgo
no flags Details
File: anaconda.log (15.43 KB, text/plain)
2014-05-27 13:59 UTC, satellitgo
no flags Details
File: environ (546 bytes, text/plain)
2014-05-27 13:59 UTC, satellitgo
no flags Details
File: journalctl (270.37 KB, text/plain)
2014-05-27 13:59 UTC, satellitgo
no flags Details
File: lsblk_output (3.54 KB, text/plain)
2014-05-27 13:59 UTC, satellitgo
no flags Details
File: nmcli_dev_list (2.96 KB, text/plain)
2014-05-27 13:59 UTC, satellitgo
no flags Details
File: os_info (381 bytes, text/plain)
2014-05-27 13:59 UTC, satellitgo
no flags Details
File: program.log (65.79 KB, text/plain)
2014-05-27 13:59 UTC, satellitgo
no flags Details
File: storage.log (277.81 KB, text/plain)
2014-05-27 14:00 UTC, satellitgo
no flags Details
File: ifcfg.log (6.03 KB, text/plain)
2014-05-27 14:00 UTC, satellitgo
no flags Details
File: packaging.log (53 bytes, text/plain)
2014-05-27 14:00 UTC, satellitgo
no flags Details

Description satellitgo 2014-05-27 13:59:48 UTC
Description of problem:
install Workstation with liveinst (default) 20140527

Version-Release number of selected component:
anaconda-core-21.37-1.fc21.x86_64

The following was filed automatically by anaconda:
anaconda 21.37-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/subprocess.py", line 1326, in _execute_child
    raise child_exception
  File "/usr/lib64/python2.7/subprocess.py", line 709, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iutil.py", line 126, in _run_program
    preexec_fn=chroot, cwd=root, env=env)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iutil.py", line 182, in execWithRedirect
    log_output=log_output, binary_output=binary_output)[0]
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1592, in install
    env_prune=['MALLOC_PERTURB_'])
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 1608, in write
    self.install()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2357, in writeBootLoaderFinal
    storage.bootloader.write()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/bootloader.py", line 2427, in writeBootLoader
    writeBootLoaderFinal(storage, payload, instClass, ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 234, in doInstall
    writeBootLoader(storage, payload, instClass, ksdata)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
OSError: [Errno 2] No such file or directory

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Workstation-x86_64-r rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.15.0-0.rc7.git0.1.fc21.x86_64
other involved packages: python-libs-2.7.6-7.fc21.x86_64
product:        Fedora
release:        Fedora release 21 (Rawhide)
type:           anaconda
version:        rawhide

Comment 1 satellitgo 2014-05-27 13:59:52 UTC
Created attachment 899511 [details]
File: anaconda-tb

Comment 2 satellitgo 2014-05-27 13:59:53 UTC
Created attachment 899512 [details]
File: anaconda.log

Comment 3 satellitgo 2014-05-27 13:59:54 UTC
Created attachment 899513 [details]
File: environ

Comment 4 satellitgo 2014-05-27 13:59:55 UTC
Created attachment 899514 [details]
File: journalctl

Comment 5 satellitgo 2014-05-27 13:59:56 UTC
Created attachment 899515 [details]
File: lsblk_output

Comment 6 satellitgo 2014-05-27 13:59:57 UTC
Created attachment 899516 [details]
File: nmcli_dev_list

Comment 7 satellitgo 2014-05-27 13:59:58 UTC
Created attachment 899517 [details]
File: os_info

Comment 8 satellitgo 2014-05-27 13:59:59 UTC
Created attachment 899518 [details]
File: program.log

Comment 9 satellitgo 2014-05-27 14:00:00 UTC
Created attachment 899519 [details]
File: storage.log

Comment 10 satellitgo 2014-05-27 14:00:01 UTC
Created attachment 899520 [details]
File: ifcfg.log

Comment 11 satellitgo 2014-05-27 14:00:02 UTC
Created attachment 899521 [details]
File: packaging.log

Comment 12 satellitgo 2014-05-27 14:32:08 UTC
Another user experienced a similar problem:

workstation -f21 (rawhide) x86_64 20140527 install with custom: std partitioning happened at "installing bootloader"

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Workstation-x86_64-r rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         3.15.0-0.rc7.git0.1.fc21.x86_64
other involved packages: python-libs-2.7.6-7.fc21.x86_64
package:        anaconda-core-21.37-1.fc21.x86_64
packaging.log:  07:29:00,557 INFO packaging: rsync exited with code 2
product:        Fedora
reason:         OSError: [Errno 2] No such file or directory
release:        Fedora release 21 (Rawhide)
version:        rawhide

Comment 13 Brian Lane 2014-05-27 21:29:22 UTC
The actual problem is that rsync failed:

06:56:32,615 INFO program: Running... rsync -pogAXtlHrDx --exclude /dev/ --exclude /proc/ --exclude /sys/ --exclude /run/ --exclude /boot/*rescue* --exclude /etc/machine-id /mnt/install/source/ /mnt/sysimage
06:57:23,171 INFO program: File-list index 3299 not in 4474 - 6715 (read_ndx_and_attrs) [sender]
06:57:23,171 INFO program: rsync error: protocol incompatibility (code 2) at rsync.c(736) [sender=3.1.0]
06:57:23,172 INFO program: rsync: [sender] write error: Broken pipe (32)
06:57:23,172 DEBUG program: Return code: 2

Which would seem to indicate mismatched rsync versions -- except that makes not sense when syncing to another local disk. I don't see any obvious disk errors in the logs so I'm not sure why it failed.

Does this happen every time?

Comment 14 Michal Vrzal 2014-05-28 10:15:55 UTC
Another user experienced a similar problem:

During installation from gnome LiveCD installation stoped working after few minutes. I created an user and root and after a while this error occured. 
I used default settings.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Workstation-i686-raw rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         3.15.0-0.rc7.git0.1.fc21.i686
other involved packages: python-libs-2.7.6-7.fc21.i686
package:        anaconda-core-21.37-1.fc21.i686
packaging.log:  05:02:33,034 INFO packaging: rsync exited with code 2
product:        Fedora
reason:         OSError: [Errno 2] No such file or directory
release:        Fedora release 21 (Rawhide)
version:        rawhide

Comment 15 Paul Fee 2014-05-28 15:50:37 UTC
Another user experienced a similar problem:

Fresh install of Rawhide nightly ISO (KDE spin).

Installation to a virtual machine hosted on a physical Fedora 20 machine running KVM and virt-manager.

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-KDE-x86_64-rawhide-2 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         3.15.0-0.rc7.git0.1.fc21.x86_64
other involved packages: python-libs-2.7.6-7.fc21.x86_64
package:        anaconda-core-21.37-1.fc21.x86_64
product:        Fedora
reason:         OSError: [Errno 2] No such file or directory
release:        Fedora release 21 (Rawhide)
version:        rawhide

Comment 16 Paul Fee 2014-05-28 15:56:37 UTC
(In reply to bcl@redhat.com from comment #13)
> 
> Does this happen every time?

Yes, I tried installation a couple of times and got the same error each time.

Comment 17 Adam Williamson 2014-05-28 19:43:38 UTC
Another user experienced a similar problem:

Did a straight click-through install of an Xfce live image built from today's Rawhide plus systemd 213-3.fc21 and kernel 3.15.0-0.rc7.git1.1.fc21 .

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=20140528-soas-x86_64 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         3.15.0-0.rc7.git1.1.fc21.x86_64
other involved packages: python-libs-2.7.6-8.fc21.x86_64
package:        anaconda-core-21.37-1.fc21.x86_64
packaging.log:  14:41:54,567 INFO packaging: rsync exited with code 2
product:        Fedora
reason:         OSError: [Errno 2] No such file or directory
release:        Fedora release 21 (Rawhide)
version:        rawhide

Comment 18 Adam Williamson 2014-05-28 19:46:28 UTC
This seems to be affecting a lot of (or possibly all) Rawhide live installs, so nominating as an Alpha blocker, criterion....eh, we don't have a straightforward 'live install must work' criterion, let's say "The installer must be able to complete an installation to a single disk using automatic partitioning." (https://fedoraproject.org/wiki/Fedora_21_Alpha_Release_Criteria#Disk_layouts ).

Comment 19 Mace Moneta 2014-05-29 14:29:38 UTC
I'm seeing this same error with a local rsync copy using rsync-3.1.0-4.fc20. When I revert to rsync-3.1.0-3.fc20, I have no problem.

...
Backups/serenity/var/lib/yum/yumdb/i/
Backups/serenity/var/lib/yum/yumdb/i/2e58fb1ad1887ad2f34aa5b51cfd73c08361afb1-ibus-anthy-python-1.5.5-4.fc20-noarch/
Backups/serenity/var/lib/yum/yumdb/i/2e58fb1ad1887ad2f34aa5b51cfd73c08361afb1-ibus-anthy-python-1.5.5-4.fc20-noarch/changed_by => Backups/serenity/var/lib/yum/yumdb/A/eec8c8c95a066f2603d65df17573f02a9b7a21d4-AtomicParsley-0.9.5-2.fc20-x86_64/installed_by
File-list index 130969 not in 130974 - 132186 (read_ndx_and_attrs) [sender]
rsync error: protocol incompatibility (code 2) at rsync.c(736) [sender=3.1.0]

Comment 20 Adam Williamson 2014-05-29 18:51:15 UTC
The change between 3.1.0-3 and 3.1.0-4 appears to have been a backport of upstream commit 740551d6576f28b42bc53c3e7e7e150adafa20e4 , https://git.samba.org/?p=rsync.git;a=commit;h=740551d6576f28b42bc53c3e7e7e150adafa20e4 . That itself was supposedly a reversion of a much earlier commit , https://git.samba.org/?p=rsync.git;a=commit;h=78286a03 . The relevant upstream bug report here is https://bugzilla.samba.org/show_bug.cgi?id=10290 - that bug report led to the reversion of the 2011 change.

That bug report has an interesting comment: "Anyone needing to interact with a buggy 3.1.0 version can make use of the --protocol=30 option to get things going (until it can be updated to the (upcoming) 3.1.1)." But I'm really having trouble keeping track of exactly what the hell's going on here, given that we've applied these changes to our *3.1.0* package.

Comment 21 Scott Dowdle 2014-05-29 19:03:20 UTC
I can confirm this bug on a fresh rebuild of Fedora 20.  The live installer built before the rsync update works fine.  The live installer dies at the "post install" portion of the install.  I also see this in the volumous error output:

11:29:06,593 INFO program: Running... rsync -pogAXtlHrDx --exclude /dev/ --exclude /proc/ --exclude /sys/ --exclude /run/ --exclude /boot/*rescue* --exclude /etc/machine-id /mnt/install/source/ /mnt/sysimage
11:30:02,099 INFO program: File-list index 3973 not in 6888 - 9732 (read_ndx_and_attrs) [sender]
11:30:02,100 INFO program: rsync error: protocol incompatibility (code 2) at rsync.c(736) [sender=3.1.0]
11:30:02,101 INFO program: rsync: [sender] write error: Broken pipe (32)

Ouch.

Comment 22 Michal Luscon 2014-05-30 09:09:16 UTC
The fix for #1050081 has been reverted. I am sorry for any inconvenience.

Comment 23 Fedora Update System 2014-05-30 13:23:18 UTC
rsync-3.1.0-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/rsync-3.1.0-5.fc20

Comment 24 Chris Lumens 2014-05-30 17:12:09 UTC
*** Bug 1102977 has been marked as a duplicate of this bug. ***

Comment 25 Scott Dowdle 2014-05-30 20:14:06 UTC
I verified that the updated packages fixes the issue for me on my Fedora 20 remix.  Thanks.

Comment 26 Fedora Update System 2014-06-01 00:01:39 UTC
rsync-3.1.0-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.