Bug 110156 - yum.conf does not reflect the changes of the download structure of fedora
yum.conf does not reflect the changes of the download structure of fedora
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-15 10:22 EST by Ralph Angenendt
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-21 07:58:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralph Angenendt 2003-11-15 10:22:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031110 Firebird/0.7

Description of problem:
The URLs for the core and updates repositories have been changed to
<http://download.fedora.com/pub/fedora/linux/...>
while the baseurls in the included yum.conf still point to
<baseurl=http://fedora.redhat.com/releases/fedora-core-$releasever>,
which only gives a 404 error at the moment. This leads to pretty much
confusion on mailing lists or on #fedora at irc.freenode.net, as an
"official" yum.conf cannot be found anywhere.

Version-Release number of selected component (if applicable):
yum-2.0.4-2

How reproducible:
Always

Steps to Reproduce:
1. Install yum-2.0.4-2
2. Run yum check-update (or yum install component) with the included
yum.conf 
3. 
    

Actual Results:  [root@logout etc]# yum check-update
Gathering header information file(s) from server(s)
Server: Fedora Core 1 - i386 - Base
retrygrab() failed for:
  http://fedora.redhat.com/releases/fedora-core-1/headers/header.info
  Executing failover method
failover: out of servers to try
Error getting file
http://fedora.redhat.com/releases/fedora-core-1/headers/header.info
[Errno 4] IOError: HTTP Error 404: Not Found


Expected Results:  yum should have checked for updates

Additional info:
Comment 1 Jean Francois Martinez 2003-11-16 02:11:28 EST
This is crucial for Fedora's reputation.   It is also present in
rhn-applet.   The quickest and most transparent way of fixing it (I
repeat this is CRUCIAL) is to fix the website in order to make it
match what is in yum.conf: a symlink in the right place and problem
solved.
Comment 2 Max Kanat-Alexander 2003-11-20 04:48:30 EST
This is a DUPLICATE of some other bug, I believe, which should be
RESOLVED FIXED.

-M
Comment 3 Jeff Johnson 2003-11-21 07:58:43 EST
OK, resolved.

Note You need to log in before you can comment on or make changes to this bug.