Bug 1101577 - [RFE] Support for virtio-blk Data Plane (rhev)
Summary: [RFE] Support for virtio-blk Data Plane (rhev)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Tomas Jelinek
QA Contact: Israel Pinto
URL:
Whiteboard:
: 1181396 (view as bug list)
Depends On: 1013157 1101572 1101574 1211689 1214311
Blocks: 1101569 1261707
TreeView+ depends on / blocked
 
Reported: 2014-05-27 14:36 UTC by Hai Huang
Modified: 2016-03-09 20:46 UTC (History)
17 users (show)

Fixed In Version: ovirt-3.6.0-3
Doc Type: Enhancement
Doc Text:
Red Hat Enterprise Virtualization 3.6 supports virtio-blk data plane, a QEMU feature that increases performance in heavy I/O scenarios. This allows virtual machines to be configured with additional QEMU threads on the host to offload disk I/O processing from the main emulation thread. The recommended number of threads varies, but is a trade-off between additional threads overhead (increasing the load on the hypervisor in general) and offloading benefits on per-disk basis (heavy I/O virtual machines would benefit most). Note, virtio-blk data plane must be configured per virtual machine for all disks. This feature is not supported for the virtio-scsi interface.
Clone Of: 1101569
Environment:
Last Closed: 2016-03-09 20:46:18 UTC
oVirt Team: Virt
sherold: Triaged+
ylavi: testing_beta_priority+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC

Description Hai Huang 2014-05-27 14:36:24 UTC
+++ This bug was initially created as a clone of Bug #1101569 +++

Description of problem:

Official support for Data Plane (was tech preview in RHEL7.0)


Version-Release number of selected component (if applicable):
RHEL7.1

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Ademar Reis 2014-08-11 21:51:01 UTC
FYI, a summary of the status of data-plane as being delivered with the RHEL7.1 package (rhev flavor): https://bugzilla.redhat.com/show_bug.cgi?id=1101569#c1

Comment 6 Scott Herold 2015-01-13 14:36:51 UTC
*** Bug 1181396 has been marked as a duplicate of this bug. ***

Comment 7 Itamar Heim 2015-01-29 10:55:17 UTC
hai - any limitation from guest os support for either rhel or windows (need of guest driver?)

Comment 9 Ademar Reis 2015-01-29 14:42:31 UTC
(In reply to Itamar Heim from comment #7)
> hai - any limitation from guest os support for either rhel or windows (need
> of guest driver?)

No need for guest driver changes to enable dataplane, it's fully contained in QEMU.

As a heads-up, the next logical step is to support virtio-{blk,scsi} multi-queue. This is already in RHEL6/7, not sure about virtio-win.

Comment 10 Michal Skrivanek 2015-03-23 09:12:22 UTC
we would go with per-VM setting enabling the support, no pinning.
not sure about making the number of threads configurable. Can we start with 1?

Comment 11 Scott Herold 2015-03-31 14:04:06 UTC
(In reply to Michal Skrivanek from comment #10)
> we would go with per-VM setting enabling the support, no pinning.
> not sure about making the number of threads configurable. Can we start with
> 1?

Yes, agree per VM setting to enable functionality.  Let's start with 1 thread, but have an advanced option for customers to enable more threads.

Comment 12 Michal Skrivanek 2015-03-31 14:24:49 UTC
advanced might be custom properties and a hook
though when we introduce a new feature it's typically not much work to do it right at least at VDSM API level

Comment 13 Israel Pinto 2015-08-11 12:21:00 UTC
Bugs found:
1. Migration bug: Migration failed libvirtError in migrateToURI3 (https://bugzilla.redhat.com/show_bug.cgi?id=1252099)
2. Failed to start VM if IO threads are bigger then 127: VM stuck in wait for launch after update vm IO Threads value (https://bugzilla.redhat.com/show_bug.cgi?id=1251899)

Comment 14 Israel Pinto 2015-08-26 18:14:32 UTC
moving to on_qa, wait for storage and scale results.

Comment 15 Aharon Canan 2015-10-08 08:35:09 UTC
There was nothing special to do from storage perspective but regression testing.
Our regression is ongoing always and we saw nothing till now so looks like we are good

Comment 17 Israel Pinto 2015-10-11 11:02:49 UTC
Verify with:
RHEVM Version: 3.6.0-0.18.el6 
vdsm: vdsm-4.17.8-1.el7ev
libvirt: libvirt-1.2.17-5.el7

Comment 19 errata-xmlrpc 2016-03-09 20:46:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.