Bug 1101585 - [RFE] - Need ability to configure nexus mechanism driver
Summary: [RFE] - Need ability to configure nexus mechanism driver
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: z2
: Installer
Assignee: Brad P. Crochet
QA Contact: Alexander Chuzhoy
URL: https://trello.com/c/Z0ZKlJt8/218-nee...
Whiteboard:
Depends On: 1125978 1211650
Blocks: 1154162 1093544 1154159
TreeView+ depends on / blocked
 
Reported: 2014-05-27 14:46 UTC by Steve Reichard
Modified: 2015-04-14 13:47 UTC (History)
7 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.4.0-1.el6ost
Doc Type: Enhancement
Doc Text:
With this update, a new feature adds the ability to configure the Cisco Nexus ML2 mechanism with the following additional fields: switch name, ip address, username, password, and ssh port.
Clone Of:
Environment:
Last Closed: 2014-11-04 17:00:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Steve Reichard 2014-05-27 14:46:52 UTC
Description of problem:

In OSP4, nexus support was provided via a monolithic nexus driver.  since only ML2 will be supported with Icehouse/OSP 5, equivalent functionality should be enabled so that there is no regression in support.

BZ 1042571 seems to be request to add the feature to neutron itself.  This BZ is to enable the provisioning.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Mike Orazi 2014-09-10 18:27:17 UTC
I believe the ofi portion is complete and this is a request to enable it through the staypuft ui.

Comment 3 Brad P. Crochet 2014-10-01 16:33:30 UTC
PR available:

https://github.com/theforeman/staypuft/pull/325

Comment 6 Alexander Chuzhoy 2014-10-07 14:41:00 UTC
Verified: ruby193-rubygem-staypuft-0.4.0-2.el6ost.noarch
rhel-osp-installer-0.4.1-2.el6ost.noarch


This option is available in the "Services Configuration" page for the Neutron service.
At least one ML2 mechanism must be selected from "Open vSwitch", "L2 Population", "Cisco Nexus".

Selecting "Cisco Nexus" opens sub page with fields (with validation) to configure access to switch.

Comment 8 errata-xmlrpc 2014-11-04 17:00:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.