Bug 11016 - install's -m flag does not create suid/gid perms
Summary: install's -m flag does not create suid/gid perms
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: fileutils   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-24 16:31 UTC by mw
Modified: 2018-12-04 14:16 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-24 16:31:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mw 2000-04-24 16:31:39 UTC
install -d -m2755 a
ls -ld a
drwxr-xr-x   2 root     root         4096 Apr 24 04:11 a/

similar problem with mkdir:

mkdir -p -m2755 b
ls -ld b
drwxr-xr-x   2 root     root         4096 Apr 24 04:23 b/

The problem is fixed in fileutils-4.0-21 of RH 6.2, but I have not seen
an update for 6.1.  I created quite a few rpms which work correctly on
our 6.2 boxes, but they are all messed up on the 6.1 boxes---hence I think
an updated fileutils is important to upload.

Thx,

Mate

Comment 1 Bernhard Rosenkraenzer 2000-06-15 21:51:26 UTC
The package from 6.2 installs cleanly on 6.1 - there's no reason not
to use it.
The reasoning behind ignoring setuid/setgid in install was an
over-paranoid security thought from one of the fileutils maintainers
(the official version still has that "feature", I've just patched it
out for 6.2).


Note You need to log in before you can comment on or make changes to this bug.