Bug 110161 - BuildRequires problem: libpng-devel rpm is ok but not the 'libpng-devel' provided by libpng10-devel
BuildRequires problem: libpng-devel rpm is ok but not the 'libpng-devel' prov...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libpng10 (Show other bugs)
1
All Linux
low Severity low
: ---
: ---
Assigned To: Matthias Clasen
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-15 11:57 EST by Dries Verachtert
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-19 12:11:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dries Verachtert 2003-11-15 11:57:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
To build the rpm, 'libpng-devel' is needed. The rpm libpng-devel provides this but also libpng10-devel provides this:

[dries@delirium dries]$ rpm -q --provides libpng10-devel
libpng-devel = 1.0.13
libpng10-devel = 1.0.13-9

When libpng10-devel is installed and libpng-devel is not installed, the build halts in ./configure. Reason: one of the first tests in configure is a check if gcc is able to compile something. The spec file contains the line
LIBS="-lfreetype -lpng -ljpeg -lz -lnsl"; export LIBS
So the small test in the configure fails when libpng-devel is not installed.

When you remove the libpng10-devel and install libpng-devel, the rpmbuild works without problems.




Version-Release number of selected component (if applicable):
php-4.3.3-6, libpng10-devel

How reproducible:
Always

Steps to Reproduce:
1. make sure libpng-devel is not installed
2. make sure libpng10-devel is installed
3. try to rebuild the php source rpm
    

Actual Results:  Build fails

Expected Results:  A lot of php rpms in my RPMS directory :-)

Additional info:

interesting part in the config.log when libpng10-devel is installed and libpng-devel is not installed:

configure:2334: checking for C compiler default output
configure:2337: gcc -O2 -g -march=i386 -mcpu=i686 -fPIC -I/usr/kerberos/include     conftest.c -lfreetype -lpng -ljpeg -lz -lnsl -L/usr/kerberos/lib
 -lssl -lcrypto -lgssapi_krb5 -lkrb5 -lcom_err -lk5crypto -lresolv -ldl -lz   >&5
/usr/bin/ld: cannot find -lpng
collect2: ld returned 1 exit status
configure:2340: $? = 1
configure: failed program was:
| #line 2313 "configure"
| /* confdefs.h.  */
|
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| /* end confdefs.h.  */
|
| int
| main ()
| {
|
|   ;
|   return 0;
| }
configure:2379: error: C compiler cannot create executables
See `config.log' for more details.
Comment 1 Joe Orton 2003-11-18 04:57:21 EST
The only bug is that libpng10-devel should not Provide: libpng-devel,
since the two are not the same thing.

Note You need to log in before you can comment on or make changes to this bug.