Bug 110168 - Up2date crashes if configured to use an http proxy.
Up2date crashes if configured to use an http proxy.
Status: CLOSED DUPLICATE of bug 102272
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-15 15:34 EST by Sam Varshavchik
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/sysconfig/rhn/sources (1.44 KB, text/plain)
2003-11-15 15:35 EST, Sam Varshavchik
no flags Details
/etc/sysconfig/rhn/up2date (3.37 KB, text/plain)
2003-11-15 15:37 EST, Sam Varshavchik
no flags Details

  None (edit)
Description Sam Varshavchik 2003-11-15 15:34:21 EST
Description of problem:

up2date aborts with the following traceback if configured to use an
http proxy, and the box is not directly routable to the Internet (it
tries to do a direct connect nevertheless).

Version-Release number of selected component (if applicable):

4.1.16

How reproducible:

Always

Steps to Reproduce:
1. Firewall the test box so that it does not have direct Internet access.
2. up2date --configure, and specify an HTTP proxy.
3. Run up2date, and try to check for updates.
  
Actual results:

[root@ny root]# up2date
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1365, in
onChannelsPageNext
    self.pList.run()
  File "/usr/share/rhn/up2date_client/packageList.py", line 117, in run
    self.progressCallback)
  File "/usr/share/rhn/up2date_client/rhnPackageInfo.py", line 315, in
getAvailableAllArchPackageList
    package_list = availablePackageList(
  File "/usr/share/rhn/up2date_client/rhnPackageInfo.py", line 153, in
availablePackageList
    progressCallback = progressCallback)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 110, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/share/rhn/up2date_client/repoDirector.py", line 20, in
listPackages
    return self.handlers[channel['type']].listPackages(channel,
msgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 226, in
listPackages
    msgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line
204, in listPackages
    agent = "Up2date 3.9/Yum")
  File "/usr/share/rhn/up2date_client/repoBackends/urlUtils.py", line
312, in fetchUrl
    agent = agent)
  File "/usr/share/rhn/up2date_client/repoBackends/urlUtils.py", line
106, in open_resource
    return opener.open(request)
  File "/usr/lib/python2.2/urllib2.py", line 328, in open
    '_open', req)
  File "/usr/lib/python2.2/urllib2.py", line 307, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.2/urllib2.py", line 824, in http_open
    return self.do_open(httplib.HTTP, req)
  File "/usr/lib/python2.2/urllib2.py", line 809, in do_open
    raise URLError(err)
urllib2.URLError: <urlopen error (113, 'No route to host')>
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1431, in
onSkippedPagePrepare
    self.__preparePackageList()
  File "/usr/share/rhn/up2date_client/gui.py", line 1317, in
__preparePackageList
    self.pList.run()
  File "/usr/share/rhn/up2date_client/packageList.py", line 117, in run
    self.progressCallback)
  File "/usr/share/rhn/up2date_client/rhnPackageInfo.py", line 315, in
getAvailableAllArchPackageList
    package_list = availablePackageList(
  File "/usr/share/rhn/up2date_client/rhnPackageInfo.py", line 153, in
availablePackageList
    progressCallback = progressCallback)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 110, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/share/rhn/up2date_client/repoDirector.py", line 20, in
listPackages
    return self.handlers[channel['type']].listPackages(channel,
msgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 226, in
listPackages
    msgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line
204, in listPackages
    agent = "Up2date 3.9/Yum")
  File "/usr/share/rhn/up2date_client/repoBackends/urlUtils.py", line
312, in fetchUrl
    agent = agent)
  File "/usr/share/rhn/up2date_client/repoBackends/urlUtils.py", line
106, in open_resource
    return opener.open(request)
  File "/usr/lib/python2.2/urllib2.py", line 328, in open
    '_open', req)
  File "/usr/lib/python2.2/urllib2.py", line 307, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.2/urllib2.py", line 824, in http_open
    return self.do_open(httplib.HTTP, req)
  File "/usr/lib/python2.2/urllib2.py", line 809, in do_open
    raise URLError(err)
urllib2.URLError: <urlopen error (113, 'No route to host')>
TypeError: hide() takes no arguments (2 given)
[root@ny root]# 
Script done on Sat 15 Nov 2003 03:31:53 PM EST

Expected results:


Additional info:
Comment 1 Sam Varshavchik 2003-11-15 15:35:22 EST
Created attachment 95998 [details]
/etc/sysconfig/rhn/sources
Comment 2 Sam Varshavchik 2003-11-15 15:37:12 EST
Created attachment 95999 [details]
/etc/sysconfig/rhn/up2date
Comment 3 Michael Young 2003-11-16 10:38:42 EST
triage->duplicate 102272
Duplicate of bug 102272
Comment 4 Nils Philippsen 2003-11-29 06:19:35 EST

*** This bug has been marked as a duplicate of 102272 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:00:01 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.