Bug 1101773 - ServerManagerBean does not notify comm layer of maintenance mode during start up after install
Summary: ServerManagerBean does not notify comm layer of maintenance mode during start...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Core Server
Version: JON 3.2
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ER01
: JON 3.2.3
Assignee: John Sanda
QA Contact: Jeeva Kandasamy
URL:
Whiteboard:
Depends On: 1101770
Blocks: 1079598
TreeView+ depends on / blocked
 
Reported: 2014-05-27 21:47 UTC by John Sanda
Modified: 2014-09-05 15:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1101770
Environment:
Last Closed: 2014-09-05 15:40:49 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1079598 None None None Never

Internal Links: 1079598

Description John Sanda 2014-05-27 21:47:16 UTC
+++ This bug was initially created as a clone of Bug #1101770 +++

Description of problem:
When the server starts for the first time after installation, if there is a problem during start up, the server is put into maintenance mode, but we are not notifying the comm layer. This means that incoming agent requests will not get rejected as they should.


Steps to Reproduce:
1. Do a default installation, rhqctl install 
2. Start only the server and the agent, rhqctl start --server --agent
3. Verify that the server is put in maintenance mode since the storage client subsystem cannot initialize
4. Wait for the discovery queue to get populated

Actual results:
The server goes into maintenance mode and the discovery queue gets populated.

Expected results:
The server should go into maintenance mode, but we should not have anything in the discovery queue.


Additional info:

Comment 1 John Sanda 2014-05-28 21:49:09 UTC
Fix has been pushed to the release/jon3.2.x branch.

commit hash:  d3a9bc2c72

Comment 5 Jeeva Kandasamy 2014-08-19 11:40:11 UTC
Verified with updated patch. Works as mentioned in description,
------
The server should go into maintenance mode, but we should not have anything in the discovery queue.
------

Version:
JBoss Operations Network
Version : 3.2.0.GA Update 03
Build Number : bca1bc8:e19c43d
GWT Version : 2.5.0
SmartGWT Version : 3.0p

Steps followed:
1. Did a default installation, rhqctl install 
2. Applied patch
3. Started only the server and the agent, rhqctl start --server --agent
4. Verified that the server is put in maintenance mode since the storage client subsystem cannot initialize
4. Waited for 15 minutes, discovery queue didn't get populate and there is agent entry under 'Administration->Topology->Agents'


Note You need to log in before you can comment on or make changes to this bug.