Bug 11018 - openssl - generating a certificate request
openssl - generating a certificate request
Status: CLOSED WORKSFORME
Product: Red Hat Secure Web Server
Classification: Retired
Component: secureweb (Show other bugs)
3.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-24 13:17 EDT by pdavies1
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-20 17:47:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description pdavies1 2000-04-24 13:17:42 EDT
RedHat 6.2 Professional - Secure Web Server

In section 3.5.2 of the Secure Web Server manual, it describes how to
generate your certificate:

/usr/bin/openssl req -new -key /etc/httpd/conf/server.key -out
/etc/httpd/conf/server.csr

In the manual is shows one of the lines you will be prompted to enter as
being "Server Host Name[]:" But in practise when you run the above command,
it does not actually ask you for that line, but does ask you for all the
rest of the ones described in that section of the manual.

As a result, when you then go to setup the certificate with VeriSign, it
fails. Because you did not supply a valid server name. But of course it is
not possible to supply a valid one, as the command does not prompt you for
one when you are creating your server.crt on your RH6.2 Pro system using
openssl.

So how does one create a secure server with this software without it
prompting you for this line?
Comment 1 Nalin Dahyabhai 2000-07-18 15:07:22 EDT
Are you instead prompted for a common name (which might mistakenly be
labeled "your name"?)
Comment 2 pdavies1 2000-07-20 17:47:27 EDT
I did not report this bug report !!!
Comment 3 Nalin Dahyabhai 2000-07-23 18:33:00 EDT
Okay, then I'll just close it.

Note You need to log in before you can comment on or make changes to this bug.