Bug 110180 - Packaging error - perl-DB_File, perl-CGI, perl-CPAN not obsoleted.
Packaging error - perl-DB_File, perl-CGI, perl-CPAN not obsoleted.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-15 23:47 EST by Sam Varshavchik
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-25 20:41:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Varshavchik 2003-11-15 23:47:03 EST
Description of problem:

Perl 5.8.0 had several modules packaged in separate RPMS: DB_File.pm
packaged separately in its own RPM, CGI.pm packaged separately in its
own RPM, ditto for CPAN.pm.  Perl 5.8.1 installs them in the main RPM.
 Upgrading 5.8.0 to FC1 leaves old modules lying around, for no good
reason.

"Obsoletes: perl-DB_File, perl-CGI, perl-CPAN" is needed.

Version-Release number of selected component (if applicable):

5.8.1-92

How reproducible:

Always.

Steps to Reproduce:
1. Install RH9 with perl 5.8.0
2. Upgrade to FC 1
  
Actual results:

A bunch of stuff gets left over in /usr/lib/perl5/5.8.0

Expected results:


Additional info:

This results in some extra baggage being inserted by the installer:
compat-db-4.0 (to satisfy the dependency in the obsolete DB_File.pm)...
Comment 1 Michael Young 2003-12-09 05:15:10 EST
Actually they are obsoleted, but incorrectly. perl obsoletes 
perl-CGI <= 2:2.81-88
perl-CPAN <= 2:1.61-88
perl-DB_File <= 2:1.804-88
Unfortunately a well patched RHL 9 box will have 
perl-CGI = 2:2.81-88.3
perl-CPAN = 2:1.61-88.3
perl-DB_File = 2:1.804-88.3
which aren't obsoleted by the perl spec file.
Probably perl should obsolete
perl-CGI < 2:2.81-89
etc. or similar to allow for this and future RHL 9 patches.
Comment 2 Michael Young 2004-04-22 07:54:51 EDT
This seems to be fixed by perl-5.8.3-16.

Note You need to log in before you can comment on or make changes to this bug.