Bug 1102049 - kickstart ignored
Summary: kickstart ignored
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
Depends On:
Blocks: 1090893
TreeView+ depends on / blocked
Reported: 2014-05-28 11:50 UTC by Gene Czarcinski
Modified: 2014-05-28 18:56 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2014-05-28 13:25:49 UTC
Type: Bug

Attachments (Terms of Use)

Description Gene Czarcinski 2014-05-28 11:50:13 UTC
Description of problem:
When I attempted to do a kickstart install (ks=http://...) with a DVD iso created based on the 5/27/14 rawhide with anaconda-21.37-1, the kickstart was ignored.  Spacifying a bad URL for the kickstart errored out saying bad url.

I have a "collection" of DVD isos so I went back and tried them.

I tried a DVD iso created on 5/7/14 with anaconda 2.35-1 and it worked.
I tried a DVD iso created on 5/20/14 with anaconda-21.36-1 and it worked.
I tried a DVD iso created on 5/21/14 with anaconda-21.37-1 and it DID NOT work.

Version-Release number of selected component (if applicable):

How reproducible:

I am not sure what documentation you need ... just ask.

Comment 1 David Shea 2014-05-28 13:25:49 UTC
There was a recent change to the command line parsing that introduced a bug in parsing the boot parameters. Fixed in commit db2641e4d4cd6ce1a4d28aa924863ba8aba6327e

Comment 2 Gene Czarcinski 2014-05-28 13:47:29 UTC
Thanks.  I had tracked the problem to anaconda and command line parsing and was about to check git for an update.

Comment 3 Matthew Miller 2014-05-28 15:12:03 UTC
Since we're using rawhide anaconda to generate cloud images via kickstart (by way of imagefactory), this blocks our feature to make that the default. Adding blocker just to track... Dennis tells me there should be a new build with the fix later today if all goes well.

Comment 4 Gene Czarcinski 2014-05-28 18:56:24 UTC
I got the patch, applied it to my local repository, and created an updates.img.  Testing with a DVD iso created 5/26/14  the kickstart install worked.  Having some problems with a DVD iso created 5/27/14.

Note You need to log in before you can comment on or make changes to this bug.