Bug 110206 - Can not delete static interface specific routes
Summary: Can not delete static interface specific routes
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-config-network   
(Show other bugs)
Version: 1
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: rcn-profiling
TreeView+ depends on / blocked
 
Reported: 2003-11-17 03:12 UTC by Brett Johnson
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 1.3.26-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-16 13:47:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brett Johnson 2003-11-17 03:12:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET 
CLR 1.1.4322)

Description of problem:
The gui network configuration tool will not allow me to delete static 
routes on an interface.  I believe that this is due to the fact that 
the tool may be saving route info to an incorrect file.  I believe it 
should be saving to /etc/sysconfig/networking/devices/eth?.route.  
But, it actually saves to 2 files;

/etc/sysconfig/networking/devices/route-eth?
/etc/sysconfig/network-scripts/route-eth?

I believe that this is not the general format for Redhat, but I could 
be wrong.  I've already reported a problem with ifup-routes, that may 
be related to this also.  Both have to be set the same in order for 
static routes 

Version-Release number of selected component (if applicable):
1.3.10-1

How reproducible:
Always

Steps to Reproduce:
1.Add a static route to eth0
2.Save changes and exit
3.Remove static route from eth0
4.Save changes and exit
5.Go back in and see that the route still exits
    

Additional info:

Comment 1 Harald Hoyer 2003-11-26 14:42:45 UTC
this is ok, because /etc/sysconfig/network-scripts/route-eth? is the
only place the initscripts should look into...
/etc/sysconfig/network-scripts/route-eth? is a hardlink to
/etc/sysconfig/networking/devices/route-eth?

Comment 2 Brett Johnson 2003-11-27 23:09:58 UTC
First, both Redhat 8, Redhat 9 look in both location for routing 
information.  Second, other software, including webmin, look 
in /etc/sysconfig/networking/devices for the routing info.  Third, 
these don't appear to be hardlinks on my systems, they appear to be 
separate files.  And, finally, that still doesn't address the problem 
that gui config tool won't allow me to delete a static route that has 
been added to an interface.


Note You need to log in before you can comment on or make changes to this bug.